[vtkusers] Set Scalar Data using vtkSelectEnclosedPoints

Iliana García Resines iliana_lancing at hotmail.com
Tue May 25 08:36:59 EDT 2010


I am getting incorrect results when using vtkSelectEnclosedPoints. To run the method, I have set a polydata surface that contains part of an image that I have set as the input. When I write the results into a files, I get the points inside the polydata surface, but not their real values. 

What do I need to set the scalar values of the image (whether vtkImage or vtkStructuredPoints) into the vtkSelectEnclosedPoints method? Nothing I have tried has worked out so far.

Short "pseudocode" that shows what I'm doing, just in case it is of any help:

surface  *vtkPolydata
space *vtkStructuredPoints

sep = vtk.vtkSelectEnclosedPoints()

Any ideas where to set the scalar data from the StructuredPoints?
¿Quieres conocer trucos de Windows 7? ¡Los que ya lo usan te los cuentan!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20100525/b117188c/attachment.htm>

More information about the vtkusers mailing list