[vtkusers] problem with installing VTK

Denis Barbier bouzim at gmail.com
Thu May 6 08:11:38 EDT 2010

On 2010/5/6 Tingting HAN wrote:
> Dear Officer,
> I work on linux and have python originally installed in the system:
> shau at tityro:/home/hantingting/Downloads$ python
> Python 2.6.4 (r264:75706, Dec  7 2009, 18:43:55)
> [GCC 4.4.1] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> I want to install package VTK, but there is the following problem:
> shau at tityro:/home/hantingting/Downloads$ sudo apt-get install vtk[sudo]
> password for shau:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package vtk is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> However the following packages replace it:
>   vtk-tcl
> E: Package vtk has no installation candidate
> shau at tityro:/home/hantingting/Downloads$
> And when I tried to run a file stl_decimate.py, the following error shows
> that VTK package is still not installed
> hantingting at tityro:~/Downloads/triMC3D/python$ python2.5 stl_decimate.py
> Traceback (most recent call last):
>   File "stl_decimate.py", line 9, in <module>
>     import vtk
> ImportError: No module named vtk

 You seem to be using a Debian-based distro, thus
  sudo apt-get install python-vtk
may be what you are looking for.  If not, please tell which Linux
distribution you are using.


More information about the vtkusers mailing list