[vtkusers] problem with installing VTK

Tingting HAN hihighsky at gmail.com
Thu May 6 07:32:04 EDT 2010

Dear Officer,

I work on linux and have python originally installed in the system:
shau at tityro:/home/hantingting/Downloads$ python
Python 2.6.4 (r264:75706, Dec  7 2009, 18:43:55)
[GCC 4.4.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
I want to install package VTK, but there is the following problem:
shau at tityro:/home/hantingting/Downloads$ sudo apt-get install vtk[sudo]
password for shau:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vtk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
E: Package vtk has no installation candidate
shau at tityro:/home/hantingting/Downloads$
And when I tried to run a file stl_decimate.py, the following error shows
that VTK package is still not installed
hantingting at tityro:~/Downloads/triMC3D/python$ python2.5 stl_decimate.py
Traceback (most recent call last):
  File "stl_decimate.py", line 9, in <module>
    import vtk
ImportError: No module named vtk
hantingting at tityro:~/Downloads/triMC3D/python$
Could you please give me some advice to solve the problem or to properly
install VTK?
Yours sincerely,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20100506/af782ddb/attachment.htm>

More information about the vtkusers mailing list