[vtkusers] Problem with java and vtk

Carl Trapani carl at skytopsoftware.com
Fri Jul 17 13:41:48 EDT 2009

It may be that the jawt.dll (<JDKInstall>\jre\bin for JDK installation) 
is not in your runtime path. The way jawt.dll gets into your path is 
mysterious to me. You can put it there using Eclipse runtime 
configuraiton or setting it permantly in your PATH variable (I don't 
like that), but sometimes I think the JVM sets it, specifically if you 
double click a jar file.

Hope that helps,

Guilherme Ferraz de Arruda wrote:
> Hi, i tried to compile this example:
> http://dev.artenum.com/projects/cassandra/forum/how-to-use-eclipse-and-vtk
> I did everything right, but i got this error when i try to run (at eclipse):
> Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program
> Files (x86)\Cassandra\thirdpart\vtk5.0-32b\bin\vtkRenderingJava.dll:
> Can't find dependent libraries
>        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
>        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1778)
>        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
>        at java.lang.Runtime.loadLibrary0(Runtime.java:823)
>        at java.lang.System.loadLibrary(System.java:1028)
>        at vtk.vtkPanel.<clinit>(vtkPanel.java:31)
>        at VTKSample.main(VTKSample.java:17)
> I tried to add the native library location and got the same error.
> What is wrong??
> What can i do to fix it??
> I don't have much experience with java.
> I'm using Eclipse 3.5.0 and JRE 1.6.
> Thanks for all
> _______________________________________________
> Powered by www.kitware.com
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
> Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
> Follow this link to subscribe/unsubscribe:
> http://www.vtk.org/mailman/listinfo/vtkusers

More information about the vtkusers mailing list