[vtkusers] Problem with java and vtk

J E Pf H daviddarkzero at hotmail.com
Fri Jul 17 12:42:52 EDT 2009

Hi, maybe your path is wrong. I did the same but my path is only C:\vtk5.0-32b\bin and run properly.
> From: guiep at yahoo.com.br
> Date: Fri, 17 Jul 2009 02:18:39 -0300
> To: vtkusers at vtk.org
> Subject: [vtkusers] Problem with java and vtk
> Hi, i tried to compile this example:
> http://dev.artenum.com/projects/cassandra/forum/how-to-use-eclipse-and-vtk
> I did everything right, but i got this error when i try to run (at eclipse):
> Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program
> Files (x86)\Cassandra\thirdpart\vtk5.0-32b\bin\vtkRenderingJava.dll:
> Can't find dependent libraries
> at java.lang.ClassLoader$NativeLibrary.load(Native Method)
> at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1778)
> at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
> at java.lang.Runtime.loadLibrary0(Runtime.java:823)
> at java.lang.System.loadLibrary(System.java:1028)
> at vtk.vtkPanel.<clinit>(vtkPanel.java:31)
> at VTKSample.main(VTKSample.java:17)
> I tried to add the native library location and got the same error.
> What is wrong??
> What can i do to fix it??
> I don't have much experience with java.
> I'm using Eclipse 3.5.0 and JRE 1.6.
> Thanks for all
> _______________________________________________
> Powered by www.kitware.com
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
> Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
> Follow this link to subscribe/unsubscribe:
> http://www.vtk.org/mailman/listinfo/vtkusers

Nuevo Windows Live, un mundo lleno de posibilidades. Descúbrelo.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20090717/49eafb2c/attachment.htm>

More information about the vtkusers mailing list