[vtkusers] Re: Microsoft Visual C++ Express Edition, missing MSVCR80.DLL

Goodwin Lawlor goodwin.lawlor at ucd.ie
Fri Jun 2 06:43:47 EDT 2006

Kalle Pahajoki wrote:
> Hi
> I successfully built VTK with the free MS VC++ Express Edition. But when 
> I launched python and did an "import vtk" I got an error message saying 
> "This application has failed to start because MSVCR80.dll was not found. 
> Re-installing the application may fix this problem."
> I am by no means experienced in developing on Windows, but some googling 
> revealed that you need some kind of a manifest file to get the libraries 
> linked properly. And
> sure enough, the VTK/bin directory had a bunch of manifests. So I tried 
> using the vtkpython.exe and got no errors.
> So far so good, but the problems resurfaced when I tried to package my 
> software with py2exe. After a while I get an error saying:
> error: MSVCR80.dll: No such file or directory.
> Has anyone got any insight on how to go about fixing this? Should I go 
> ask the py2exe developers? Any pointers or hints are much appreciated!

Hi Kalle,

That file is the VC8 C runtime "redistributable". It has to be in the 
same folder as your binaries or in your path. Depending on your version 
of VC8, you could have received the file when installing VC (it should 
be here:  \program files\Microsoft Visual Studio 
8\VC\redist\x86\Microsoft.VC80.CRT but this folder was omitted in the 
release version).

You could have got it when installing the .NET Framework (look here: 
\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_*). Its also contained in 
vcredist_x86.exe which is supposed to be here:
\Microsoft Visual Studio 8\SDK\v2.0\Bootstrapper\Packages\vcredist_x86\ 
... but isn't.

It seems you're supposed to install MSI3.1 to get the file now... look 
at this 

Anyway, search your machine for this file and copy it to your VTK/bin 
folder.(*) Alternatively, compile a static VTK.



* If you don't have it at all download vcredist_x86.exe here:

More information about the vtkusers mailing list