[vtkusers] Microsoft Visual C++ Express Edition, missing MSVCR80.DLL

Kalle Pahajoki kalpaha at st.jyu.fi
Fri Jun 2 05:44:49 EDT 2006


I successfully built VTK with the free MS VC++ Express Edition. But when 
I launched python and did an "import vtk" I got an error message saying 
"This application has failed to start because MSVCR80.dll was not found. 
Re-installing the application may fix this problem."

I am by no means experienced in developing on Windows, but some googling 
revealed that you need some kind of a manifest file to get the libraries 
linked properly. And
sure enough, the VTK/bin directory had a bunch of manifests. So I tried 
using the vtkpython.exe and got no errors.

So far so good, but the problems resurfaced when I tried to package my 
software with py2exe. After a while I get an error saying:
error: MSVCR80.dll: No such file or directory.

Has anyone got any insight on how to go about fixing this? Should I go 
ask the py2exe developers? Any pointers or hints are much appreciated!


Debugging is twice as hard as writing the code in the first place.
Therefore, if you write the code as cleverly as possible, you are, by
definition not smart enough to debug it.        -- Brian W. Kerninghan

More information about the vtkusers mailing list