[vtkusers] Re: linux VTK CVS build , undefined symbol: _ZTV24vtkVolumeRayCastFunction ???

Dan White dan at chalkie.org.uk
Thu Jul 21 09:18:46 EDT 2005

Hi Carl,

I got the cvs from
cvs udpate -D 20050719 -dP

removed all vtk stuff from every where
apart from my CVS VTK directory

did the
make install

still getting the same error about
undefined symbol: _ZTV24vtkVolumeRayCastFunction

any more ideas?


On Jul 21, 2005, at 3:06 PM, Charl P. Botha wrote:

> On 7/21/05, Dan White <dan at chalkie.org.uk> wrote:
>> so it looks like the CVS version is broken for libvtkRendering.so
>> on linux?
> A CVS checkout from 2005-07-19 worked for me on Linux, including
> Python bindings.  I had a problem similar to yours, but that was
> because I was explicitly importing the patented kit and the old
> library was still lying around in my build directory.
> Perhaps you could double check that there are no old libraries lying
> around somewhere on your PYTHONPATH or your LD_LIBRARY_PATH.  Other
> than that, you could try reverting to 2005-07-19.  Although the
> dashboard wasn't looking too healthy on that day, it was working fine
> on my rig.  cvs udpate -D 20050719 -dP is your friend. :)
> Good luck,
> Charl
> --  
> charl p. botha http://cpbotha.net/ http://visualisation.tudelft.nl/
> c.p.botha ||at|| ewi.tudelft.nl - tu delft work-related email
> cpbotha ||at|| cpbotha.net - everything else

Dr. Daniel James White BSc. (Hons.) PhD
Bioimaging Coordinator
Nanoscience Centre and Department of Biological and Environmental  
Division of Molecular Recognition
Ambiotica C242
PO Box 35
University of Jyväskylä
FIN 40014

+358 14 260 4183 (work)
+358 468102840 (mobile)
dan at chalkie.org.uk
white at cc.jyu.fi

More information about the vtkusers mailing list