[vtkusers] This old "java.lang.UnsatisfiedLinkError: VTKInit"!!!

Ali - saveez at hotmail.com
Mon Jan 3 06:45:01 EST 2005


Here is my set-up:

vtk 4.4.2
JDK for x86_64
Fedora Core 3 X86_64

It was not straight to compile vtk under these prefs; the trick was to build 
ccmake for the 64-bit arch and then link the libs to the 64-bit version of 
the GL libs. I also needed to have the vtk javabeans, so I set the java 
parser to the javabeans parser and compiled the bean jar successfully. The 
jar includes the required manifest file.

The problem is when I want to run a minimal java example, by importing the 
jar bean into BDK, I get this old error:

java.lang.UnsatisfiedLinkError: VTKInit
        at vtk.vtkObject.VTKInit(Native Method)
        at vtk.vtkObjectBase.<init>(vtkObjectBase.java:42)
        at vtk.vtkObject.<init>(vtkObject.java:6)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native 

The following solutions have been tried:

- The libraries are in the path as checked by:

- The libraries are loaded in the BDK code:
	<and the rest>

- The libraries are NOT mangled as checked by nm:
	# nm /usr/local/lib64/vtk/libvtkCommonJava.so |grep vtkObject_VTKInit
	000000000009393c T Java_vtk_vtkObject_VTKInit

- Note that the installed java binaries are in fact 64-bit which is in 
consistant with the compiled vtk binaries (64-bit again).

- I have tried the same experiment under (32-bit) win xp and got exactly the 
same results.

I do not know what I am missing here. Any clues would be appreciated.


FREE pop-up blocking with the new MSN Toolbar - get it now! 

More information about the vtkusers mailing list