[vtkusers] UnsatisfiedLinkError (Linux/Java)

Prabhu Ramachandran prabhu at aero.iitm.ernet.in
Tue Oct 24 08:54:28 EDT 2000


	Try this.  In the file java/Makefile change the following lines

        -o libvtkJava$(SHLIB_SUFFIX) -L. ${XLDFLAGS} ${LDLIBS} \
        ${XLIBS} -lXext ${X_PRE_LIBS} -lX11 ${X_EXTRA_LIBS} ${JAVA_CXX_LIB}


        -o libvtkJava$(SHLIB_SUFFIX) -L. ${XLDFLAGS} ${LDLIBS} \
        ${XLIBS} -lXext ${X_PRE_LIBS} -lX11 -lXt ${X_EXTRA_LIBS} \

The only difference being the -lXt added in the last line.

After this, remake vtk by running make on the base vtk source dir.  If 
this is a premade deb from SuSe, also file a bug. :)


>>>>> "Karin" == Karin Faulhaber <faulhabe at ipf.uni-karlsruhe.de> writes:

    Karin> /usrc2/image/faulhabe/vtk312/java/libvtkJava.so:
    Karin> /opt/vtk312/my_vtk_shared_libs/libVTKGraphics.so: undefined
    Karin> symbol: XtStrings at
    Karin> java.lang.ClassLoader$NativeLibrary.load(Native Method)
    Karin> etc.

    Karin> I've read about this problem in the archive: I am supposed
    Karin> to include the libXt somewhere, but where? I've tried with
    Karin> vtk/java/Makefile.in and with user.make. Maybe I put it in
    Karin> the wrong line, I'm not very familiar with Makefiles and
    Karin> libs ... I also put it in the LD_LIBRARY_PATH, bur none of
    Karin> it worked.

More information about the vtkusers mailing list