[vtkusers] UnsatisfiedLinkError (Linux/Java)

Karin Faulhaber faulhabe at ipf.uni-karlsruhe.de
Mon Oct 23 09:25:33 EDT 2000


since there seemed to be a problem with the lists mail server for a
couple of days (?) I'm sending this mail again:

after finally having installed VTK for Java on my SuSe Linux I tried to
run the example on the example code page of the vtk homepage. It
compiled just fine, but I keep getting the following error while trying
to run it:

Exception in thread "main" java.lang.UnsatisfiedLinkError:
/opt/vtk312/my_vtk_shared_libs/libVTKGraphics.so: undefined symbol:
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)

I've read about this problem in the archive: I am supposed to include
the libXt somewhere, but where? I've tried with vtk/java/Makefile.in and
with user.make. Maybe I put it in the wrong line, I'm not very familiar
with Makefiles and libs ... I also put it in the LD_LIBRARY_PATH, bur
none of it worked.

Thanks for your help
Karin Faulhaber

More information about the vtkusers mailing list