[CDash] CDash 2.4.0 PHP version requirement

Zack Galbreath zack.galbreath at kitware.com
Mon Mar 27 13:47:05 UTC 2017

Hi Arthur,

On Sat, Mar 25, 2017 at 3:44 PM, Arthur Kahlich <art at millcomputing.com>

> If  I do an installation instead of doing an update, will CDash 2.4.0 then
> work with php version 5.3.3?

As you may have suspected,CDash 2.4 requires PHP >= 5.5.9.  Thanks for
pointing out that our documentation was out of date.  I just fixed this.

Looking here,

You can see that PHP 5.3 has not received security updates since 2014.

We recently confirmed that our whole test suite passes when using PHP 7, so
for the best performance that is the version I recommend.  If that's too
cutting edge for you, I recommend using the latest patch release of PHP 5.6.

The reason I am doing the update is the CDash 2.2.3 installation (with php
> 5.3.3, php-mysql 5.3.3, mysql-community-server 5.6.35)  I currently have
> hangs about every hour and must be restarted. I have no idea why it hangs
> and I haven't had the time to try to track down why (I am not a php nor an
> sql developer and can only "mostly" read php code and sql).

Strange.  Sorry to hear that you're having this problem.  Please feel free
to report back to the mailing list with more details if you can't figure
out what's causing this.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20170327/98048e55/attachment-0001.htm>

More information about the CDash mailing list