[CDash] CDash 2.4.0 PHP version requirement

Arthur Kahlich art at millcomputing.com
Sat Mar 25 19:44:08 UTC 2017

Before I attempt to install CDash 2.4.0 on my Centos 6.6 system, which 
has php version 5.3.3, I want to know what the real php version 
requirement is because I understand the version 5.3.3 requirement as 
stated on the wiki may be very out of date.

The reason I ask is I have CDash 2.2.3 currently installed on this 
system. When I went to update it according to the instructions here:


the running of composer.phar produced an error message stating that php 
 >= 5.5.9 is required, along with a number of following error messages.

My question is:

If  I do an installation instead of doing an update, will CDash 2.4.0 
then work with php version 5.3.3?

The reason I am doing the update is the CDash 2.2.3 installation (with 
php 5.3.3, php-mysql 5.3.3, mysql-community-server 5.6.35)  I currently 
have hangs about every hour and must be restarted. I have no idea why it 
hangs and I haven't had the time to try to track down why (I am not a 
php nor an sql developer and can only "mostly" read php code and sql).

Arthur Kahlich
CTO - Hardware
Mill Computing, Inc.
Box 1531
Palo Alto CA 94302-1531
Phone: (408)480-3680
Faster, Cooler, Safer Computing.

More information about the CDash mailing list