[Cdash] Unable to add SVN URL via CDash "Project Administration"->"Repository" form

Paul Reimer paulreimer at gmail.com
Tue Feb 9 00:41:20 UTC 2010

Hello all,

I am new to CDash/CTest, but a long time CMake user. I have configured CDash
running behind an nginx frontend, with requests served via FastCGI processes
(which in turn are spawned by supervisord).

I have created a new project, and using the CTestConfig.cmake file generated
from the Project Administration page can successfully submit Experimental
builds from Linux, OS X, and Windows (thank you Kitware!)

However, I run into problems when I try to add the URL of the Subversion
repository. For any URL I enter, as soon as I click the "Update Project"
button, any text I have entered into the Repository, Username, or Password
field is lost. No rows are added to the repositories table (I checked using
pgAdmin as I am using Postgres). My project is hosted on Sourceforge, but
the php user has the appropriate auth in the ~/.subversion directory. I have
tried other Sourceforge projects, a couple Googlecode projects, and even a
CVS repo in case the problem is specifically with SVN. In all the SVN cases,
I enter an HTTP(S) URL without a trailing slash.

Please advise how I can setup a Continuous build that is compiled/tested via
the same machine running the CDash process, even if I have to manually add
it to the database.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20100208/43fff932/attachment-0002.htm>

More information about the CDash mailing list