[vtkusers] Trouble using VTK Widget with QVTK

andyjk andrewkeeling at hotmail.com
Mon Jul 9 09:56:08 EDT 2018


I have tried this but it made no difference.

There just seems to be no way to set a new custom iterator in a
QVTKOpenGLWidget  (or a QVTKWidget).

I think the issue is that I can grab the existing iterator, from the QWidget
but it has already been initialised, so any custom interactor that requires
setting up prior to initialisation fails.

The only solution if you want to use a contour widget and pointplacer, is to
use a normal VTK window as a pop-up. It looks like it cannot be displayed
inside QT which is a shame as this spoils the look of the UI.

Not sure this is a bug, just a lack of functionality. We need a way to be
able to insert our own (new) interactor into a QVTKOpenGLWidget, which
completely replaces the widgets existing iterator. I think at the moment
they clash.

I've tried all combinations of grabbing the existing QVTKWidget
RenderWindow, the renderer and the iterator vs creating New RenderWindow,
renderer, iterator and Setting them via the QWidget methods. 
No combination works - you cannot create a new window, renderer and iterator
then apply the lot via 
neither can you grab them all from the widget and modify them via

Ideally both of the above methods should be valid ways of modify the
QVTKWidget, but it seems they are not, once a custom interactor is involved.

Sent from: http://vtk.1045678.n5.nabble.com/VTK-Users-f1224199.html

More information about the vtkusers mailing list