[vtkusers] building VTK 7.1.0 on MSYS2: undefined references

Mario Emmenlauer mario at emmenlauer.de
Mon Nov 28 15:45:18 EST 2016

Thanks David for the reply. Its a bit strange because 7.0.0 worked fine,
so it must be something introduced in 7.1.0. I can also see the text
definition of the missing symbol in vtkCommonCore, so it must be the
missing linker command. Could you tell me how the dependency is defined
in VTK? I would be curious to learn the build system a bit.



On 28.11.2016 17:44, David Lonie wrote:
> According to Common/DataModel/module.cmake, vtkCommonDataModel already has a
> dependency on vtkCommonCore inside of VTK. Everything should be linked already. Hmm.
> It's likely that the mingw support needs some love. I don't think we have any
> customers that rely on it at the moment, but maybe someone can pick it up.
> On Fri, Nov 25, 2016 at 4:23 AM, Mario Emmenlauer <mario at emmenlauer.de
> <mailto:mario at emmenlauer.de>> wrote:
>     Dear All,
>     I've reported this issue already here:
>     https://gitlab.kitware.com/vtk/vtk/issues/16916
>     <https://gitlab.kitware.com/vtk/vtk/issues/16916>
>     But I hope somebody here on the mailing list might be knowledgeable about
>     how to add
>     linker dependencies inside VTK?
>     When building VTK 7.1.0 I get an error about an undefined reference on
>     MSYS2. Everything
>     works fine on Linux. The error on MSYS2 is:
>     CMakeFiles/vtkCommonDataModel.dir/objects.a(vtkDataSetAttributes.cxx.obj):vtkDataSetAttributes.cxx:(.text+0x4a7c):
>     undefined reference to
>     `vtkAOSDataArrayTemplate<long>::FastDownCast(vtkAbstractArray*)'
>     CMakeFiles/vtkCommonDataModel.dir/objects.a(vtkDataSetAttributes.cxx.obj):vtkDataSetAttributes.cxx:(.text+0x4a92):
>     undefined reference to
>     `vtkAOSDataArrayTemplate<long>::FastDownCast(vtkAbstractArray*)'
>     I think its required that vtkCommonDataModel links against vtkCommonCore? I
>     do not
>     know how to achieve this. I've tried various combinations to add the
>     dependency to
>     Common/DataModel/CMakeLists.txt but without success. How is this done correctly?
>     Cheers,
>         Mario
>     _______________________________________________
>     Powered by www.kitware.com <http://www.kitware.com>
>     Visit other Kitware open-source projects at
>     http://www.kitware.com/opensource/opensource.html
>     <http://www.kitware.com/opensource/opensource.html>
>     Please keep messages on-topic and check the VTK FAQ at:
>     http://www.vtk.org/Wiki/VTK_FAQ <http://www.vtk.org/Wiki/VTK_FAQ>
>     Search the list archives at: http://markmail.org/search/?q=vtkusers
>     <http://markmail.org/search/?q=vtkusers>
>     Follow this link to subscribe/unsubscribe:
>     http://public.kitware.com/mailman/listinfo/vtkusers
>     <http://public.kitware.com/mailman/listinfo/vtkusers>

Viele Gruesse,

    Mario Emmenlauer

BioDataAnalysis GmbH, Mario Emmenlauer      Tel. Buero: +49-89-74677203
Balanstr. 43                   mailto: memmenlauer * biodataanalysis.de
D-81669 München                          http://www.biodataanalysis.de/

More information about the vtkusers mailing list