[vtkusers] vtkCellDerivatives
Martin Genet
martin.genet at polytechnique.edu
Wed Jan 20 05:24:23 EST 2016
Thanks Andy.
Well, I might be wrong but I'm under the impression that
vtkCellDerivatives returns [du/dx, dv/dx, dw/dx, du/dy, dv/dy, ...]. Am
I wrong?
Martin
On 20/01/2016 03:07, Andy Bauer wrote:
> Hi Martin,
>
> I haven't looked closely enough at vtkTensors (I don't know if I even
> knew about it before today) but indeed the ordering output in
> vtkCellDerivatives for a velocity vector {u,v,w} needs to be [du/dx,
> du/dy, du/dz, dv/dx, dv/dy, ...] like you have it. I'm not sure when
> vtkTensors is ordered the way it is.
>
> Cheers,
> Andy
>
> On Tue, Jan 19, 2016 at 5:02 PM, Martin Genet
> <martin.genet at polytechnique.edu
> <mailto:martin.genet at polytechnique.edu>> wrote:
>
> Thanks Andy.
>
> I need to clarify something: the Derivatives function of vtkCell
> objects returns a derivs vector containing the components of the
> gradient of some vector field defined at the cell nodes; the
> components are ordered in row (as usually in C, i.e., (0,0),
> (0,1), (0,2), (1,0), (1,1), (1,2), (2,0), (2,1), (2,2)). Now in
> the CellDerivatives filter the derivs vector is used to fill a
> vtkTensors, and then the filter returns the internal vector
> storing the data of the vtkTensors. However, the components of the
> vtkTensors are ordered in column (as usually in fortran, i.e.,
> (0,0), (1,0), (2,0), (0,1), (1,1), (2,1), (0,2), (1,2), (2,2)). Is
> it on purpose that the vtkTensors store their data in column and
> not in row? Isn't it a little dangerous to mix both storage in the
> code? Thanks for the clarification!
>
> Martin
>
>
> On 18/01/2016 13:32, Andy Bauer wrote:
>> Hi Martin,
>>
>> Thanks for following up on this. I found the merge request now
>> and will look at this. In general, developers should request
>> others to do a code review on this. This can be done via
>> something like "@acbauer please review this" or sending an email
>> on this VTK list with a link to the merge request.
>>
>> Best,
>> Andy
>>
>> On Mon, Jan 18, 2016 at 6:23 AM, Martin Genet
>> <martin.genet at polytechnique.edu
>> <mailto:martin.genet at polytechnique.edu>> wrote:
>>
>> Hi Andy,
>>
>> I followed the directions, and submitted a patch (19 days
>> ago), but haven't heard anything back.
>>
>> In GitLab the merge requests counter is at 0, but when I try
>> to create a new merge request from my commit, it tells the
>> merge request already exists. Is it being reviewed somewhere?
>> Thanks!
>>
>> Martin
>>
>>
>> On 29/12/2015 13:22, Andy Bauer wrote:
>>> Hi Martin,
>>>
>>> This patch makes sense. It would need a test if you want to
>>> get your changes into VTK. The directions for contributing
>>> to VTK are at
>>> https://gitlab.kitware.com/vtk/vtk/blob/master/Documentation/dev/git/develop.md.
>>>
>>> Cheers,
>>> Andy
>>>
>>> On Mon, Dec 28, 2015 at 5:50 PM, Martin Genet
>>> <martin.genet at polytechnique.edu
>>> <mailto:martin.genet at polytechnique.edu>> wrote:
>>>
>>> Thanks Andy.
>>>
>>> What about simply adding another mode, e.g.
>>> SetTensorModeToComputeGreenLagrangeStrain, to the
>>> vtkCellDerivatives filter? Would the attached patch make
>>> sense?
>>>
>>> Martin
>>>
>>> On 28/12/2015 14:12, Andy Bauer wrote:
>>>> Hi Martin,
>>>>
>>>> Changing the name of the SetTensorModeToComputeStrain
>>>> method to something else would break backward
>>>> compatibility which is generally avoided in VTK. Other
>>>> options for this include deriving a class to compute
>>>> non-linear strain from vtkCellDerivatives if it shares
>>>> enough of the algorithm with the linearized version or
>>>> maybe just creating a new filter.
>>>>
>>>> Cheers,
>>>> Andy
>>>>
>>>> On Sat, Dec 26, 2015 at 4:36 PM, Martin Genet
>>>> <martin.genet at polytechnique.edu
>>>> <mailto:martin.genet at polytechnique.edu>> wrote:
>>>>
>>>> Dear VTK users:
>>>>
>>>> I realize that the vtkCellDerivatives filter, when
>>>> SetTensorModeToComputeStrain is activated, returns
>>>> the symmetric part of the gradient of the input
>>>> vector field, which is the linearized strain
>>>> tensor, i.e., not a proper measure of deformation
>>>> when large displacements are involved. Would that
>>>> make sense to have two different modes,
>>>> SetTensorModeToComputeLinearizedStrain or
>>>> SetTensorModeToComputeSymmetricGradient, and
>>>> SetTensorModeToComputeStrain or
>>>> SetTensorModeToComputeGreenLagrangeStrain? Thanks!
>>>>
>>>> Martin
>>>> _______________________________________________
>>>> Powered by www.kitware.com <http://www.kitware.com>
>>>>
>>>> Visit other Kitware open-source projects at
>>>> http://www.kitware.com/opensource/opensource.html
>>>>
>>>> Please keep messages on-topic and check the VTK FAQ
>>>> at: http://www.vtk.org/Wiki/VTK_FAQ
>>>>
>>>> Search the list archives at:
>>>> http://markmail.org/search/?q=vtkusers
>>>>
>>>> Follow this link to subscribe/unsubscribe:
>>>> http://public.kitware.com/mailman/listinfo/vtkusers
>>>>
>>>>
>>>
>>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20160120/7df86c8d/attachment.html>
More information about the vtkusers
mailing list