[vtkusers] Failure of VTK_MAKE_INSTANTIATOR3

Yan liuyanbc157 at gmail.com
Thu Feb 4 08:10:19 EST 2016

Hallo, everyone,

I'm doing immigration from VTK 5.4 to VTK 6.2. I have solved compiling 
problem of VTK_MAKE_INSTANTIATOR3 (Unknown CMake command 
innclude(${VTK_CMAKE_DIR}/vtkMakeInstantiator.cmake) to my CMakeLists.txt.

It works. And it is for total software compiling.

I have another part programm to my software based on VTK. 

The name of it is solvingwrapper. In it there are CMakeCache.txt  
CMakeLists.txt. It shows me that I need also use ccmake ./ to change VTK_DIR 
from VTK 5.4 to VTK 6.2. 

I have done it. But when i tried to configure (c) it. 

It shows me this failure:

 ABEMS will not be compiled due to missing BLAS and LAPACK

 CMake Error at 
   Unknown CMake command "VTK_MAKE_INSTANTIATOR3".

But actually like I said, I have already added 
include(${VTK_CMAKE_DIR}/vtkMakeInstantiator.cmake) to  
so that by compiling the whole system there is no more failure. 

Just by operating the software, it shows me that I must change VTK_DIR in 
solvingwrapper. When I have changed, then there is the failure.

So I'm confused with this. I really don't know where comes this problem, and 
how to solve it. 


Yan Liu 

More information about the vtkusers mailing list