[vtkusers] vtkGL2PSExporter in combination with QVTKRenderWindowInteractor

Stefan Lau github at stefanlau.com
Tue Jul 14 10:20:01 EDT 2015

I finally located the issue by looking at the generated svg.
The problem lies in the locale settings of the linux installation.
When I use LC_NUMERIC=en_US.utf8 the generated svg looks
correct. I don't know wether this is an issue that can be fixed
in VTK or needs to be fixed in libgl2ps.

All other image formats are affected as well. Should
I create a Bugreport for this? Thanks for all the help by the

- Stefan

Am 13.07.2015 um 15:16 schrieb David Lonie:
> This is very odd. I'm using an up-to-date arch linux with VTK built 
> from the current development branch. I just tested with today's code 
> and it's still working here. I also tried the vtk 6.1.0-8 package from 
> pacman and that works with your script, too.
> I'm not really sure what could be happening in your tests. Do the 
> other vector graphics formats (ps, eps, pdf) work?
> On Sun, Jul 12, 2015 at 4:51 AM, Stefan Lau <github at stefanlau.com 
> <mailto:github at stefanlau.com>> wrote:
>     Allright, I tried with current development version, the issue is
>     still there.
>     I also finally tried a different machine (with
>     different drivers and distro) and the issue is still there, so it
>     should not
>     only be an issue on my machine.
>     One thing I noticed though: When trying it on a live Ubuntu, I had it
>     working once ;-). After installing it on hdd, it was in the broken
>     state again.
>     What is your setup in terms of package versions etc.? I want
>     be able to get it to a working state, since I need the svgs for my
>     masters thesis.
>     - Stefan
>     Am 10.07.2015 um 18:01 schrieb David Lonie:
>>     On Fri, Jul 10, 2015 at 11:46 AM, Stefan Lau
>>     <github at stefanlau.com <mailto:github at stefanlau.com>> wrote:
>>         Allright after a short holiday, I had another few hours to
>>         debug the issue. But no success.
>>         Some other stuff that I tried (but now I'm out of ideas):
>>         * Installing everything inside a VirtualBox running Ubuntu
>>         14.04 (using the Ubuntu-provided
>>           vtk packages, which are broken btw:
>>         https://bugs.launchpad.net/ubuntu/+source/vtk6/+bug/1354127)
>>         * Using VTK 6.2 (building my own version of VTK)
>>         * Using OpenGL software rendering (I thought that maybe it's
>>         a driver issue of the intel drivers)
>>         All yield the same corrupted result: The image that I sent in
>>         the last email.
>>         I haven't tried running it on a completely different machine,
>>         since I have none available ATM.
>>         Any ideas on how I could proceed?
>>     I'd try building the current development version and see if it
>>     persists. See the 'clone' section of
>>     https://gitlab.kitware.com/vtk/vtk/blob/master/Documentation/dev/git/download.md
>>     for the information on how to get the sources. After downloading,
>>     the build process should be the same as 6.2.
>>     Dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20150714/40994de7/attachment.html>

More information about the vtkusers mailing list