[vtkusers] VTK6 migration and vtkImageData: "No scalar values found for texture input!" error in vtkOpenGLTexture

Sebastian Ordas sebastian.ordas at gmail.com
Mon Sep 29 11:25:26 EDT 2014

Dear List,

(I just realized I sent my message to ITK list instead of VTK!)

I have started getting the error "No scalar values found for texture input!"
coming from vtkOpenGLTexture, while porting my code to VTK6

More precisely, I have a vtkImageData, generated by
itkImageToVTKImageFilter, which is mapped through vtkImageResliceMapper

I have tried adding the following to itkImageToVTKImageFilter:

         m_Importer->GetOutputInformation(0 /*port number*/),
         0 /*piece*/,
         2 /*number of pieces*/,
         0 /*number of ghost levels*/);

.. but no luck!

I have also tried:

m_ImageData->GetPointData()->SetActiveAttribute (0, vtkPointData::SCALARS);

didn´t work either...

Any hint?

thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20140929/3b44acc1/attachment.html>

More information about the vtkusers mailing list