[vtkusers] QT and the vtkRenderwindow crash

Marcus D. Hanwell marcus.hanwell at kitware.com
Thu Jun 26 15:08:51 EDT 2014

On Thu, Jun 26, 2014 at 11:14 AM, Doug Hoppes <dhoppes at mbfbioscience.com> wrote:
> Hi all,
>                 I’m not sure what’s going on.  I have a class called
> VTKRenderingArea that is sub-classed from QVTKWidget.  On my QT window, I
> have placed a QWidget to put the VTK window at a specific location and made
> sure that it was promoted to VTKRenderingArea.  Everything compiles and
> links fine.
>                 When I run my application, I run into a crash in
> QVTKWidget.cxx:
>       When debugging the code, I see that the *win is null and, hence, the
> crash.  Is there something that I need to do to instantiate the
> vtkrenderwindow?  The VTKRenderingArea is a valid pointer but I have noticed
> that the QVTKPaintEngine is an uninitialized pointer.
It looks like you are missing the links to the OpenGL implementations,
or the object factory overrides. If run in a terminal you would likely
see error messages about missing overrides too. See,


for more details, and examples of the best approach to finding/linking
and initializing the object factories.

Hope that helps,


More information about the vtkusers mailing list