[vtkusers] problem with installing VTK

Denis Barbier bouzim at gmail.com
Thu May 6 11:09:47 EDT 2010

On 2010/5/6 Tingting HAN wrote:
> The linux distribution I use is Ubuntu 9.10. I tried sudo apt-get install
> python-vtk.
> shau at tityro:/home/hantingting/Downloads/triMC3D/python$ sudo apt-get install
> python-vtk
> [sudo] password for shau:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> python-vtk is already the newest version.
> python-vtk set to manually installed.
> 0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
> But when I run stl_decimate.py file, it is still the same situation:
>  hantingting at tityro:~/Downloads/triMC3D/python$ python2.5 stl_decimate.py
> Traceback (most recent call last):
>   File "stl_decimate.py", line 9, in <module>
>     import vtk
> ImportError: No module named vtk.
> So I have installed VTK, but it still can't be found.
> There are several people working on the same Linux computer in our lab. I am
> the user "hantingting", and I am not sudoer, as shown below:
> hantingting at tityro:~/Downloads/triMC3D/python$ sudo apt-get install vtk
> [sudo] password for hantingting:
> hantingting is not in the sudoers file.  This incident will be reported.
> So the user "shau" uses sudo to install VTK. Is the problem related to this?

No, if vtk is installed by apt-get, all users have access to it.

According to
python-vtk is available only with python2.6 on your distribution, so try running
   python2.6 stl_decimate.py
or even
   python  stl_decimate.py


More information about the vtkusers mailing list