[vtkusers] VTK 5.6.0 Cmake Errors

Scott Johnson Scott.Johnson at neuwave.com
Thu Jun 17 14:20:06 EDT 2010

Hi Bill,

I started with a totally clean copy of the source tree from the vtk-5.6.0.zip file and started Cmake from scratch with the same result.  I also made sure that my Binary directory was specified outside of the source directories.

Looking at the CmakeLists.txt there is an ADD_SUBDIRECTORY(Wrapping) command before the ADD_SUBDIRECTORY(Utilities) command which fails.  If I look in my Binary directory the Wrapping directory is created, so ADD_SUBDIRECTORY works up to that point.  What variable does ADD_SUBDIRECTORY look at to determine where to create the directory?  It feels like it's getting changed between lines 1083 and 1251.

I was able to do this with the 5.4.2 release.


		-- Scott

-----Original Message-----
From: Bill Lorensen [mailto:bill.lorensen at gmail.com] 
Sent: Thursday, June 17, 2010 11:12 AM
To: Scott Johnson
Cc: John Drescher; VTK
Subject: Re: [vtkusers] VTK 5.6.0 Cmake Errors

Did you ever run cmake or ccmake in the source directory. If you did,
it is prbably polluted with some build files and other stuff.

Try a completely fresh source tree and run cmake (or ccmake) outside
of the source tree.

On Thu, Jun 17, 2010 at 11:38 AM, Scott Johnson
<Scott.Johnson at neuwave.com> wrote:
> Hi John,
> Starting raw, i.e. deleting the cache and starting with an empty i:/VTK-Build directory gives me the same result.
> Thanks
>                -- Scott
> -----Original Message-----
> From: John Drescher [mailto:drescherjm at gmail.com]
> Sent: Thursday, June 17, 2010 10:32 AM
> To: Scott Johnson
> Cc: VTK
> Subject: Re: [vtkusers] VTK 5.6.0 Cmake Errors
> On Thu, Jun 17, 2010 at 11:23 AM, Scott Johnson
> <Scott.Johnson at neuwave.com> wrote:
>> Thanks John.
>> I changed the binaries path to be outside i:/VTK5.6.0 to i:/VTK-Build, with the same result.  The error message still calls out that it is trying to add the Utilities directory within VTK5.6.0.  That puzzles me.  Full error text is:
>> CMake Error at CMakeLists.txt:1251 (ADD_SUBDIRECTORY):
>>  add_subdirectory not given a binary directory but the given source
>>  directory "I:/VTK5.6.0/Utilities" is not a subdirectory of "i:/VTK5.6.0".
>>  When specifying an out-of-tree source a binary directory must be explicitly
>>  specified.
>> I also tried deleting the cmake cache.  With the same result.
>> I'm not a cmake expert by any means, but the offending line in CmakeLists.txt is:
>> It seems that it should be adding it under i:/VTK-Build rather than i:/VTK5.6.0.  How is the root directory specified to ADD_SUBDIRECTORY?  There do seem to be a number of other directories already created in VTK-Build.  Just not Utilities.
> Clear the cache and build with the default options the first time. I
> will verify that this works on my system in a few minutes. I have both
> VTK5.6 and visual studio 2008.
> John
> _______________________________________________
> Powered by www.kitware.com
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
> Please keep messages on-topic and check the VTK FAQ at: http://www.vtk.org/Wiki/VTK_FAQ
> Follow this link to subscribe/unsubscribe:
> http://www.vtk.org/mailman/listinfo/vtkusers

More information about the vtkusers mailing list