[vtkusers] FW: linking problem

hesham hesham at uni-paderborn.de
Mon Feb 21 09:07:40 EST 2005

Hi again , i download my vtk4qt3 program from this site:
http://www.matthias-koenig.net/vtkqt/ and there are no library files
inside it , I don't know what shall I do , I run the program in command
prompt but its still not working 
Can u please tell me the steps to execute my program correctly?
Or maybe you  can send the library file if u have it 
Thank you for help 
-----Original Message-----
From: Andrew Maclean [mailto:a.maclean at cas.edu.au] 
Sent: Dienstag, 15. Februar 2005 16:22
To: 'hesham'
Subject: RE: [vtkusers] problem with vtkqt
You are not linking in the library files for vtk4qt3.

From: hesham [mailto:hesham at uni-paderborn.de] 
Sent: Friday, 4 February 2005 19:59
To: vtkusers at vtk.org
Subject: [vtkusers] problem with vtkqt
Im beginner ,I want to put my vtk code in qt window because I have to
make menu and anther command button,I start to use very easy example but
when I excute the programm I had this link error 
Can you help me ,I use vtk4.2 ,qt3.3.3 and vtk4qt3,,
My code :
#include "vtkQtRenderWindow.h"
#include "vtkRenderer.h"

int main (void)
vtkRenderer *ren = vtkRenderer::New();
vtkQtRenderWindow *renWindow = vtkQtRenderWindow::New();

return 0;
linking  Error:
vtkqt.obj : error LNK2001: unresolved external symbol "public: static
class vtkQtRenderWindow * __cdecl vtkQtRenderWindow::New(void)"
(?New at vtkQtRenderWindow@@SAPAV1 at XZ)
Debug/vtkqt.exe : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.
vtkqt.exe - 2 error(s), 0 warning(s)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20050221/880f1b5b/attachment.htm>

More information about the vtkusers mailing list