[vtkusers] Re: Still no luck with sphere program

William A. Hoffman billlist at nycap.rr.com
Fri Sep 28 10:56:13 EDT 2001

Add -DVTKSTATIC to your compile lines and re-compile everything.
For an easier time with cygwin, try vtk 4.0 from cvs and cmake.


At 04:14 PM 9/28/2001 +0200, Ryan Mitchley wrote:
>Thanks to all that responded. Sorry - I should have made it clear that I'm
>using cygwin on a Win2k machine, NOT Visual C++ - and am attempting to go
>the OpenGL route.
>My original message was:
>Prabhu, I have checked the GRAPHICS_API_OBJ and it is indeed set to
>$(WIN32_OBJ). I also tried running configure without --with-opengl. The VTK
>build worked, but I get the exact same import stub undefined reference error
>messages when I try to build my test program.
>I still suspect that I need somehow to link with a library that accesses
>vtkdll.dll. If this suspicion is wrong, somebody please tell me!
>Unfortunately I don't have a cygwin .a library to do this. There are a few
>hints on the net about constructing a suitable library from the dll, but I
>don't feel I have enough information to proceed.
>Thanks for any further suggestions!
>This is the private VTK discussion list. 
>Please keep messages on-topic. Check the FAQ at: <http://public.kitware.com/cgi-bin/vtkfaq>
>Follow this link to subscribe/unsubscribe:

More information about the vtkusers mailing list