[vtkusers] Re: Still no luck with sphere program

Ryan Mitchley ryan at peralex.com
Fri Sep 28 10:14:37 EDT 2001


Thanks to all that responded. Sorry - I should have made it clear that I'm
using cygwin on a Win2k machine, NOT Visual C++ - and am attempting to go
the OpenGL route.

My original message was:

Prabhu, I have checked the GRAPHICS_API_OBJ and it is indeed set to
$(WIN32_OBJ). I also tried running configure without --with-opengl. The VTK
build worked, but I get the exact same import stub undefined reference error
messages when I try to build my test program.

I still suspect that I need somehow to link with a library that accesses
vtkdll.dll. If this suspicion is wrong, somebody please tell me!
Unfortunately I don't have a cygwin .a library to do this. There are a few
hints on the net about constructing a suitable library from the dll, but I
don't feel I have enough information to proceed.

Thanks for any further suggestions!


More information about the vtkusers mailing list