[vtkusers] Wierd problem with VTK under Mesa.

Prabhu Ramachandran prabhu at aero.iitm.ernet.in
Wed Sep 19 15:27:25 EDT 2001


I have been running into a very wierd problem with VTK (actually with
MESA).  I am using the VTK 4.0 CVS tree.  This machine is a laptop
(PII), running Debian woody, Xfree86-4.1, ATI Mach64 Rage Pro, MESA
version 3.1.  The build itself was made on a desktop and the shared
libraries were copied to the laptop.  The desktop uses nVidia's
accelerated GL libraries while the laptop uses MESA 3.1.  Earlier I
tried a build on the laptop itself (with the vtk 3.2 tree) and had
exactly the same problems.  Anyway, here is the problem.

When I load a visualization using MayaVi (which uses VTK and Tkinter)
some of the actors suddenly disappear (the Visibility of the actor is
1 and the actor is definitely in the pipeline) and I have to change
the opacity a little bit and then the actor re-appears.  However, the
actor could randomly disappear again.  This does not happen on my
desktop machine - and I have heard of no bug reports with mayavi that
do this.  I am pretty sure it isnt a bug there.  Sometimes the actor
appears but isnt coloured, when it should be.

This is also not an X server bug.  The same thing happens when I run
VTK applications on the laptop remotely on the desktop.  I guess the
most obvious thing to do is to upgrade Mesa and will do so shortly but
I am curious to know if anyone else had similar problems?


More information about the vtkusers mailing list