[vtkusers] A bug???

xujianzhong xujianzhong at 126.com
Mon May 28 02:50:36 EDT 2001


For mouse interactions, if you use vtk3.2, you should modify function
WindowProc in vtkMFCRenderView.cpp, change the line:

    return vtkHandleMessage(this->m_hWnd, message, wParam, lParam);


    return vtkHandleMessage2(this->m_hWnd, message, wParam, lParam,

it will be ok, but I also have the problem of perormance when using vtk 3.2.

xu jianzhong

-----Original Message-----
·¢¼þÈË: Shu-Yen Wan <sywan at mail.cgu.edu.tw>
ÊÕ¼þÈË: vtkusers at public.kitware.com <vtkusers at public.kitware.com>
ÈÕÆÚ: 2001Äê5ÔÂ26ÈÕ 2:56
Ö÷Ìâ: Re: [vtkusers] A bug???

>  I haven't got on the vtk messages for quite a while and may have
>missed something critical.
>  I have the same problem as described in the below message --
>after installing vtk3.2 and rebuilding my VC++6.0 applications,
>there shows a message window, warning for some obsolet functions
>and all of mouse interactions, e.g., rotating, scaling, picking, do not
>work! Moreover, the performance of generating 3D surfaces are
>significantly degraded. Is it normal? Or is there a way to get around.
>  Any insights or recommendations is appreciated.
>----- Original Message -----
>From: "TzuYi Yu" <tyyu01 at mail.apol.com.tw>
>To: <vtkusers at public.kitware.com>
>Sent: Friday, May 25, 2001 9:21 AM
>Subject: [vtkusers] A bug???
>> Dear Vtker:
>>   I currently download the vtk 3.2 (the provious one I have is 3.12)
>> and install it on my pc (with OS: Window2000, VC++6.0).  I use to
>> have several VTK applications developed by Visual C++ 6.0, they
>> run ok under vtk 3.1.  When I install the vtk 3.2, and recompile
>> those applications, they compile ok, but when I run the codes,
>> they DON'T have any reactions to the mouse -- ie, NO rotation
>> nor zoom in/out!  I though it must be my fault, and try to see
>> what I did in my applications.  After spending a lot of time, I
>> give up.  But I try to see the VC code (located in the Sample
>> directory) come with vtk 32.  After I compile the Sample code,
>> I run it (it work fine), and open the file (the weldedSpheres.vtk),
>> then press the mouse trying to rotate / zoom the object -- guess what?
>> IT DOES NOT WORK either!  But it works fine with vtk3.1 before!
>> So, the vtk 3.2 does not support MFC mouse interaction or is it just
>> a bug?   Or do I make anything wrong?   Please help me to solve
>> this problem.
>> Thanks for all helps.
>> Robert
>> _______________________________________________
>> This is the private VTK discussion list.
>> Please keep messages on-topic. Check the FAQ at:
>> Follow this link to subscribe/unsubscribe:
>> http://public.kitware.com/mailman/listinfo/vtkusers
>This is the private VTK discussion list.
>Please keep messages on-topic. Check the FAQ at:
>Follow this link to subscribe/unsubscribe:

More information about the vtkusers mailing list