[vtkusers] A bug???

TzuYi Yu tyyu01 at mail.apol.com.tw
Thu May 24 21:21:08 EDT 2001

Dear Vtker:

  I currently download the vtk 3.2 (the provious one I have is 3.12)
and install it on my pc (with OS: Window2000, VC++6.0).  I use to 
have several VTK applications developed by Visual C++ 6.0, they 
run ok under vtk 3.1.  When I install the vtk 3.2, and recompile 
those applications, they compile ok, but when I run the codes, 
they DON'T have any reactions to the mouse -- ie, NO rotation 
nor zoom in/out!  I though it must be my fault, and try to see 
what I did in my applications.  After spending a lot of time, I 
give up.  But I try to see the VC code (located in the Sample 
directory) come with vtk 32.  After I compile the Sample code, 
I run it (it work fine), and open the file (the weldedSpheres.vtk),
then press the mouse trying to rotate / zoom the object -- guess what?
IT DOES NOT WORK either!  But it works fine with vtk3.1 before! 
So, the vtk 3.2 does not support MFC mouse interaction or is it just 
a bug?   Or do I make anything wrong?   Please help me to solve 
this problem.   

Thanks for all helps. 


More information about the vtkusers mailing list