[vtkusers] vtk impressions / linux problem and solution

Michael Zawrotny zawrotny at mailer.sb.fsu.edu
Thu Mar 29 09:58:35 EST 2001

(this was originally sent directly to Kitware feedback,  Will 
Schroeder's response suggested that it might be of interest
to the list also)

I recently downloaded vtk and bought the 2nd edition of the Schroeder,
et. al book in order to evaluate vtk as a platform for a project that
I'm starting.

Overall, I must say that I am quite impressed with both the software
and the book (at least what I have read so far).  My project is very
much in the area of data visualisation and a tool like vtk seems to
fit it much better than having to do all of the work in raw OpenGL/GLUT.

However, I ran into one problem that was very nearly a show-stopper
for me.  When I tried to run demos from either the pre-compiled 3.2 from 
your web site or after compiling it from the source, I always got a
segmentation violation.  This was on two of my Linux boxes, one running
RedHat 7.0, the other Slackware 7.1.  In both cases, the solution for
me was to remove mesa and install the SGI open source openGL noted


I'm not complaining about the software.  You are providing a package
that is large, complicated, and specialized, for which I am quite
appreciative.  The reason that I am telling you about this issue is
so that you can be aware of it and take whatever steps you deem
appropriate to mitigate the problem.


Michael Zawrotny

Michael Zawrotny
411 Molecular Biophysics Building
Florida State University                | email:  zawrotny at sb.fsu.edu
Tallahassee, FL 32306-4380              | phone:  (850) 644-0069 

More information about the vtkusers mailing list