[vtkusers] the next unsatisfiedLinkError (no vtkJava in java.library.path)

Karin Faulhaber faulhabe at ipf.uni-karlsruhe.de
Thu Oct 26 01:45:24 EDT 2000

Jeff Lee wrote:
> Hi,
> I'm assuming that you configured vtk with the -java flag, seeing as
> how libs like libVTKContribJava.so were built.  I think that
> libvtkJava.so should be wherever you set your JAVA_CLASS_HOME
> environmnent variable to in your user.make file.  I have included my
> user.make for reference...
> -Jeff

Hi again,

not exactly ... when I used the --with-java flag I had this problem with
the Makefile not finding dependent classes and so on (it was on the list
in May I think). I found a solution in the archive which worked: 
after configuring without java I put in the system.make:

BUILD_JAVA    = build_java
CLEAN_JAVA    = clean_java
then gmake. And everything worked fine.

My JAVA_CLASS_HOME is on vtk31/java, but this libvtkJava.so just isn't
there. Anyway - I should find it with the find command if it was there.

That's what I did:


1. user.make


JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/linux

2. classpath

export CLASSPATH='.:/usrc2/image/faulhabe/vtk31/java'

3. java/Makefile.in

        -o libvtkJava$(SHLIB_SUFFIX) -L. ${XLDFLAGS} ${LDLIBS} \
        ${XLIBS} -lXext ${X_PRE_LIBS} -lX11 ${X_EXTRA_LIBS}
(added -lXt)

4. configure

./configure --with-opengl --with-shared --with-contrib
(I tried it with mesa and changed that according to Prabhu Ramachandran
because of the error with "undefined symbol: OSMesaMakeCurrent"

5. system.make

BUILD_JAVA    = build_java
CLEAN_JAVA    = clean_java

6. gmake

7. Links

made links to all .so-files (according to the Linux-howto) in a new

8. .bashrc

export LD_LIBRARY_PATH=/usrc2/image/faulhabe/vtk31/my_vtk_shared_libs
export CLASSPATH='.:/usrc2/image/faulhabe/vtk31/java/vtk'


I'm growing desperate ...

More information about the vtkusers mailing list