[vtkusers] Core dump in Cube.cxx with vtk in RedHat7.0

Jerome, Ron Ron.Jerome at nrc.ca
Wed Oct 18 09:27:57 EDT 2000


It seems your not alone.  I just tried vtk on the box that I recently
upgraded to RedHat 7.0 and got the same result.  I am using a Matrox G200
video card with DRI enabled.  Interestingly, other OGL programs work.  I had
a version of GLUT 3.7 on that machine and it compiles and runs just fine.

Ron Jerome
Institute for Chemical Process and 
Environmental Technology
National Research Council Canada

-----Original Message-----
From: Tom G. Smith (B75826) [mailto:smitty at kcc.com]
Sent: Tuesday, October 17, 2000 5:04 PM
To: support at kitware.com
Cc: vtkusers at public.kitware.com; jkerins at kcc.com; cpieper at kcc.com
Subject: [vtkusers] Core dump in Cube.cxx with vtk in RedHat7.0

In addition to tcl scripts failing, I get a similar core dump from
Cube.cxx, after installing vtk 3.1.2 on RedHat 7.0:

sh-2.04$ cp /opt/vtk/graphics/examplesCxx/Cube.cxx .
sh-2.04$ vud `which vtkbuildmake`
sh-2.04$ vtkbuildmake Cube
sh-2.04$ make -f Cube.make Cube
-DHAVE_UNISTD_H -I. -I/opt/vtk/common -I/opt/vtk/patented
-I/opt/vtk/graphics/examplesCxx  -I/opt/vtk/graphics -DVTK_USE_GRAPHICS
-I/opt/vtk/imaging -DVTK_USE_IMAGING -I/opt/vtk/contrib -DVTK_USE_CONTRIB
-DVTK_USE_OGLR    -I/usr/X11R6/include -c Cube.cxx -o Cube.o
-DHAVE_LIMITS_H -DHAVE_UNISTD_H -I. -I/opt/vtk/common -I/opt/vtk/patented
-I/opt/vtk/graphics/examplesCxx  -I/opt/vtk/graphics -DVTK_USE_GRAPHICS
-I/opt/vtk/imaging -DVTK_USE_IMAGING -I/opt/vtk/contrib -DVTK_USE_CONTRIB
-DVTK_USE_OGLR    -I/usr/X11R6/include Cube.o
/opt/vtk/imaging/libVTKImaging.so /opt/vtk/contrib/libVTKContrib.so
/opt/vtk/graphics/libVTKGraphics.so /opt/vtk/common/libVTKCommon.so
-L/usr/X11R6/lib -lGL -ldl -lpthread \
-L/usr/X11R6/lib -lSM -lICE  \
-lSM -lICE -lXext -lXt -lX11 -lm
sh-2.04$ ./Cube
Segmentation fault (core dumped)
sh-2.04$ gdb -c core -e Cube -d .
#0  0x40b876d0 in glXGetCurrentContext () from /usr/lib/libGL.so.1

This e-mail is intended for the use of the addressee(s) only and may contain
privileged, confidential, or proprietary information that is exempt from
disclosure under law.  If you have received this message in error, please
inform us promptly by reply e-mail, then delete the e-mail and destroy any
printed copy.   Thank you.


This is the private VTK discussion list. 
Please keep messages on-topic. Check the FAQ at:
Follow this link to subscribe/unsubscribe:

More information about the vtkusers mailing list