linux/x11 problem

Les Schaffer godzilla at
Sun Sep 5 12:00:17 EDT 1999

in upgrading from VTK 2.1 to 2.4 and then trying the nightly build
from Sept 2, i find the following problem: 

when i run inside the python interpreter, there is no rendering
done in the pop-up window until i either shade and unshade the window
or switch desktops and come back again. if i try to click the mouse
inside the bare window, the app segfaults.

the hang takes place in the system call select().

the python interpreter with VTK 2.1 worked flawlessly with this latest 
X (, so something has changed since....

is there anyone on this list that either has this problem or would
like to help track down and solve this bug?


les schaffer

This is the private VTK discussion list.  Please keep messages on-topic.
Check the FAQ at: <>
To UNSUBSCRIBE, send message body containing "unsubscribe vtkusers" to
<majordomo at>.  For help, send message body containing
"info vtkusers" to the same address.     Live long and prosper.

More information about the vtkusers mailing list