[vtk-developers] gitlab-push woes
ben.boeckel at kitware.com
Sun Mar 22 11:18:37 EDT 2015
On Sun, Mar 22, 2015 at 09:51:43 -0400, Utkarsh Ayachit wrote:
> How about using @robot instead of Do:? That way, we are consistent:
> @robot merge
> @robot check
> @buildbot test
It would be @kwrobot first of all, but "Do:" parsing is done at the same
time as all the other trailers (and is currently the *only* part of
comments kwrobot looks at). Since "Do:" is, IMO, the longer-term
solution, I'd like to work towards it being the consistent one.
> >> 2) Recognition is better than remembering.
> How about adding support for 'help' e.g.
> @buildbot help
> @robot help
> And both will come back with a message describing the available
> actions and what they do. The first KWrobot check (which gets
> triggered automatically) can put a comment saying you can use
> "@buildbot help and @robot help for available actions". That way
> kwrobot doesn't need to be kept up-to-date with buildbot support
> commands (which will evolve -- just this weekend, I added a new
> command 'superbuild' to trigger a superbuild from a ParaView merge
Well, commands can have arguments, but they aren't supported yet (as
there haven't been any). That sounds like a better use of an argument
rather than a separate command to me. The kwrobot help would likely just
be a pointer back into the repo's documentation anyways, so adding a
link on a successful check just removes the "help" noise altogether.
More information about the vtk-developers