[vtk-developers] A note regarding: std::min and std::max.

Andrew Maclean andrew.amaclean at gmail.com
Sun Mar 1 20:16:08 EST 2015

Thanks for letting me know about that.

In summary, the VTK version of FindMPI.cmake works perfectly so there is no
problem. Maybe these changes need to be propagated to the CMake version.

I was testing using the CMake version of FindMPI. I also had uninstalled an
older version of MPI but the registry key was still there and this meant
that it couldn't find mpiexec.exe in C:/Program Files/Microsoft MPI/Bin.
Once I removed this key everything worked but the CMake version doesn't
find the the lib or include files as it doesn't know the path C:/Program
Files (x86)/Microsoft SDKs/MPI.

I have just run the VTK version of FindMPI and it works perfectly so there
are no issues there. It found the lib and include directories using the
paths set by the install of MS-MPI.

I'm doing a build now on the master and will run the tests and will let you
know how it goes.


On Mon, Mar 2, 2015 at 11:49 AM, Ben Boeckel <ben.boeckel at kitware.com>

> On Sun, Mar 01, 2015 at 19:06:39 +1100, Andrew Maclean wrote:
> > I've been watching nemesis for the past few days, the segfaults are
> caused
> > by a GL version mismatch. On the plus side the compiles are showing no
> > errors!
> Unfortunately, Windows doesn't give real hardware access to more than
> one session and a separate user is logged in right now (I'm in the
> process of moving all dashboards to that user), so all it gets is
> whatever Windows' kernel supports. That should be fixed on the runs
> Monday night).
> It is also my main Windows development machine, so there may need to be
> some setup so I can use it without disrupting the dashboards (I can't
> run as the user with the dashboards running continuously because of
> ParaView's windows stealing focus and other window management
> deficiencies in Windows).
> > I downloaded MS-MPI and discovered the FindMPI does not work with
> > it so I created a test and manually entered paths etc. and tried that. I
> > suspect you are using the 2012 version of MPI, FindMPI works with that
> > version. Anyway, I have contacted Todd with some suggested fixes to
> FindMPI.
> What errors have you seen? It would be nice to get the fixes into CMake
> itself as well. Maybe we need to look in other registry keys for the
> right path? Did you install it to your user or the machine?
> --Ben

Andrew J. P. Maclean

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtk-developers/attachments/20150302/8ebab3a6/attachment.html>

More information about the vtk-developers mailing list