[vtk-developers] Windows7 VTK + Tcl + KWWidgets

Petar Petrov pip010 at gmail.com
Fri Dec 2 04:13:57 EST 2011

Hello Community,
I'm experiencing some problems when trying to run a VTK+KWWidgets on
Windows 7 64bit, all built in x86 32bit mode.

I trully believe KWWidgets should be depricated and removed in flavor of Qt.

However, I am supporting a product ,developed with KWWidgets GUI.

So issues I experience:

(1) Installing latest 8.5x Active Object TCL for Windows 7 AMD64 was
always installing the 64bit version while I wanted to bind to my 32bit
VTK+KWWidgets build. I was forced to use the Tcl 8.4.13 win install.

I heard there is a light Tcl version provided from kitware?

(2) I checked all the CMake parameters when building the KWWidgets,
however when trying to build it I always receive error missing <tcl.h>

I did add it manually and the build was succesful.

(3) My application gives: Error Initializing tcl/tk

I debugged the KWWidgets initialization routine and I found out that
the paths where it looks for init.tcl are out of the question: some
relative to the location where my executable is. I tried setting env
var TCL_LIBRARY and TK_LIBRARY to the folder of tcl and init.tcl in
particular,but to no effect :(

I will appreciate any feedback to what I might be missing, but I've
tried several times and always reproducing the issues with KWWidgets,
latest cmake and latest vtk :(

I guess I can hardcode my paths in the KWWidgets code, but it is not
elegant and might bring more trouble :(

All the best,
Petar Petrov

More information about the vtk-developers mailing list