[vtk-developers] Limit output of VTK wrappers

Andy Cedilnik andy.cedilnik at kitware.com
Thu Jan 6 11:44:50 EST 2005


Hi Ken,

It already does that:

Building Java Wrappings
/home/andy/vtk/VTK-bin/Common/vtkXMLFileOutputWindowJava.cxx...
syntax error
*** SYNTAX ERROR found in parsing the header file
/home/andy/vtk/VTK/Common/vtkXMLFileOutputWindow.h before line 64 ***
make[1]: ***
[/home/andy/vtk/VTK-bin/Common/vtkXMLFileOutputWindowJava.cxx] Error 1
make: *** [default_target] Error 2

For the following change:

58:  // Description:
59:  // Put the text into the log file without processing it.
60:  virtual void DisplayTag(const char*);
61:  jdshafjah
62:
63:
64:  protected:
65:  vtkXMLFileOutputWindow() {};
66:  virtual ~vtkXMLFileOutputWindow() {};

Is that ok?

          Andy

Moreland, Kenneth wrote:

>Like you, I only use the output when debugging.  However, I find I use
>it often (pretty much any time the wrapper fails) to narrow down the
>lines of code that caused the wrapper to fail (which is usually between
>the last successfully parsed function and the line reported by the
>wrapper code).
>
>Is there a simple change to the wrapper code that can print out the last
>successfully parsed function in addition to the line in which the
>failure occurred?  If that was in place I would have no need for the
>verbose output.
>
>-Ken
>
>   ****      Kenneth Moreland
>    ***      Sandia National Laboratories
>***********  
>*** *** ***  email: kmorel at sandia.gov
>**  ***  **  phone: (505) 844-8919
>    ***      fax:   (505) 844-0833
>
>
>  
>
>>-----Original Message-----
>>From: Andy Cedilnik [mailto:andy.cedilnik at kitware.com] 
>>Sent: Thursday, January 06, 2005 9:24 AM
>>To: Moreland, Kenneth
>>Cc: Brad King; vtk-developers
>>Subject: Re: [vtk-developers] Limit output of VTK wrappers
>>
>>Hi Ken,
>>
>>In theory yes, but I don't think it is worth investing time 
>>to redesign wrappers to take an extra argument. I guess we 
>>could change the build of the wrappers by putting an #ifdef 
>>into the vtkParse.y. The main question is do you care about 
>>the output? Do you rely on the output? The wrappers do work 
>>exactly the same, so if you do not care about the output, 
>>then I would say let's just leave it out.
>>
>>The only time I find the output useful is when debugging and 
>>even then rarely. Please if this is not the case for you (or 
>>anybody else), share your thought.
>>
>>Thank you.
>>
>>       Andy
>>
>>Moreland, Kenneth wrote:
>>
>>    
>>
>>>Could this also be a CMake option?
>>> 
>>>
>>>      
>>>
>>>>>To see the second output you can run make the following way:
>>>>>
>>>>>DEBUG=1 make
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>or
>>>>
>>>>  make DEBUG=1
>>>>
>>>>for more platforms.  I suggest we rename it to
>>>>VTK_WRAPPING_OUTPUT=1 to be a bit more specific and avoid the 
>>>>namespace violation.
>>>>
>>>>-Brad
>>>>_______________________________________________
>>>>vtk-developers mailing list
>>>>vtk-developers at vtk.org
>>>>http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>>_______________________________________________
>>>vtk-developers mailing list
>>>vtk-developers at vtk.org
>>>http://www.vtk.org/mailman/listinfo/vtk-developers
>>> 
>>>
>>>      
>>>
>>--
>>Andy Cedilnik
>>Kitware Inc.
>>
>>
>>
>>    
>>
>
>  
>


-- 
Andy Cedilnik
Kitware Inc.




More information about the vtk-developers mailing list