[CDash] Upgrading from 2.0.2 to 2.4.0

Zack Galbreath zack.galbreath at kitware.com
Thu Jul 27 13:54:51 UTC 2017

On Wed, Jul 26, 2017 at 6:01 PM, François Bertel <fbopensource at gmail.com>

> Hi Zack,
> The output is empty:
> $ sudo -u mypostgresuser psql cdash mypostgresuser
> cdash=# \conninfo
> You are connected to database "cdash" as user "mypostgresuser" via socket
> in "/var/run/postgresql" at port "5432".
> cdash=# SELECT buildin FROM buildupdate
> I also tried build2update instead buildupdate (is it a typo?) but this
> gives the same empty line.
> Note that the section in github that you are pointing at is the master
> branch. I compared it with the Release-2-2-2 tag: I don't see much
> difference besides styling/formatting with some extra whitespaces added to
> master, notably at the pdo_query() line.
> master:
> pdo_query("INSERT INTO build2update (buildid,updateid) VALUES ('" .
> $query_array['buildid'] . "','" . $query_array['buildid'] . "')");
> Release-2-2-2:
> pdo_query("INSERT INTO build2update (buildid,updateid) VALUES
> ('".$query_array['buildid']."','".$query_array['buildid']."')");

Great, sounds like that section worked then.  The idea behind this upgrade
step was to remove the "buildid" column from the "buildupdate" table and
store this info in "build2update" instead.

Still, I'm not sure why the upgrade step errored out for you.  Maybe try
clicking the "Upgrade CDash" button again to see if this behavior repeats
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20170727/f57d71e3/attachment-0001.htm>

More information about the CDash mailing list