[CDash] "install" test issues

Nils Gladitz nilsgladitz at gmail.com
Tue Oct 27 09:35:34 UTC 2015

On 10/26/2015 08:34 PM, Nils Gladitz wrote:
> On 26.10.2015 19:38, Zack Galbreath wrote:
>> I'm also running a  PostgreSQL submission (nix.kitware) and I'm not 
>> encountering the same failing tests that you are.  It looks like your 
>> site is failing during the install test, but further details are 
>> scarce.  If you get a chance, could you see if there's any relevant 
>> details in any of the error logs (CDash/PHP/postgres)?
> I have no idea what is going on there

I set up a new instance on a different machine for testing.

One issue I found seems to be 
which in my case resulted in 'database "cdash" does not exist'.

I think it tries the "cdash" database here because no database name was 
given and "cdash" happens to be the name of my database user; I assume 
it was working for you because in your case there was an existing 
database with the name of your user(?)

pdo_select_db("$CDASH_DB_NAME") seems to help in my case but I don't 
know if that is the correct fix.

On a somewhat related note the "install" test seems to falsely pass when 
using a user without database creation privileges:
   test 1
       Start 1: install

   1: Test command: /usr/bin/php 
   1: Test timeout computed to be: 1500
   1: /var/www/html/CDash/tests/test_install.php
   1: All Tests
   1: Error connecting to host postgres database.
   1: Tried names 'host' and 'postgres'
   1: Error connecting to host postgres database.
   1: Tried names 'host' and 'postgres'
   1: Error File: /var/www/html/CDash/tests/test_install.php on line: 
34: error query(CREATE DATABASE)
   1/1 Test #1: install ..........................   Passed    0.08 sec

   The following tests passed:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20151027/35a5bcab/attachment-0001.htm>

More information about the CDash mailing list