[Cdash] Dashboard view only shows last build with APPEND, but build page shows both

O'Shea, David OShea.D at emsglobaltracking.com
Tue Aug 17 09:47:10 UTC 2010

Hi David,
Thanks for your response and suggested workaround!  With regards to
using an SVN trunk installation of CDash, that is possible.  I don't
want to annoy our IT administrator too much, though, so is it fairly


	From: David Cole [mailto:david.cole at kitware.com] 
	Sent: Tuesday, 17 August 2010 12:33 AM
	To: O'Shea, David
	Cc: cdash at public.kitware.com
	Subject: Re: [Cdash] Dashboard view only shows last build with
APPEND, but build page shows both
	On Mon, Aug 16, 2010 at 11:00 AM, David Cole
<david.cole at kitware.com> wrote:

		On Fri, Aug 13, 2010 at 12:42 AM, O'Shea, David
<OShea.D at emsglobaltracking.com> wrote:

			Hi all,
			I'm using 'ctest -S' to run a script which
performs configure, build
			('make all'), test, coverage, and then an
additional build ('make
			doc'), and submitting the result to CDash 1.6.4.
			Here is what I think is the "interesting" part
of the script:
			ctest_configure(OPTIONS [...])
			# tried with and without "APPEND" in
ctest_build() above
			ctest_start("Experimental" APPEND)
			# tried with and without the additional call to
ctest_start() above
			ctest_build(TARGET "doc"
			ctest_submit(PARTS Build)
			For the purposes of my test, I've made the first
ctest_build() report
			1 warning plus 2 errors, and the second
ctest_build() report 4
			The issue I'm having is that, after the first
ctest_submit(), the main
			dashboard page in CDash shows in the "Build"
columns the warnings and
			errors from the first ctest_build() (1 warning
plus 2 errors), but
			once the second ctest_submit() has been
executed, only the results of
			the second ctest_build() are shown (0 errors and
4 warnings).
			When I click on the build name in the "Build
Name" column to see the
			details of the build, in the "Current Build"
table, it shows the total
			errors (2) and warnings (5), which is what I'd
expect to see on the
			main dashboard page.
			I assume this is a bug, and not by design?

		Correct -- this *was* a bug in CDash. I know the fix was
committed to svn trunk of CDash within the past several weeks. Is there
any way you can try this scenario with an "svn trunk" installation of
CDash, or do you not have control over the CDash server...?

		It should be fixed in svn trunk of CDash, and in the
next official release (1.8, sometime later this year?).


			As a workaround, I would have liked to have been
able to use
			ctest_build() to build both targets at once, but
from the
			documentation it seems this is not possible, and
I can't make a CMake
			target which depends on both "doc" and "all"
either.  The only option
			I can see then is to have CMakeLists.txt
optionally make "all" depend
			on "doc" (I don't want to do this all the time,
so would need to pass
			this in as an option via ctest_configure()).
Any other suggestions
			are welcome!

	Another suggestion worth considering: build your documentation
as a test, and control whether it is run by whatever means suit you
best: a cmake option to control a conditional add_test, or the "INCLUDE"
or "EXCLUDE" option of ctest_test to match by name at run time.

			Thanks in advance,
			David O'Shea
			Senior Engineer
			EMS SATCOM Pacific Pty Ltd.
			OShea.D at emsglobaltracking.com
			T: +61 8 8260 8187
			Cdash mailing list
			Cdash at public.kitware.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20100817/9c39a52b/attachment-0003.htm>

More information about the CDash mailing list