Difference between revisions of "TubeTK/OsiriX"

From KitwarePublic
Jump to navigationJump to search
Line 8: Line 8:
# Main application
# Main application
'''svn co https://osirix.svn.sourceforge.net/svnroot/osirix osirix'''
'''svn co https://osirix.svn.sourceforge.net/svnroot/osirix osirix'''
# OsiriX plugins
'''svn co https://osirixplugins.svn.sourceforge.net/svnroot/osirixplugins osirixplugins'''


== Build FAQs ==
== Build FAQs ==
Line 21: Line 18:
# OsiriX Development Guide  
# OsiriX Development Guide  
http://osirix.svn.sourceforge.net/viewvc/osirix/Documentation/Guides/Development/index.html
http://osirix.svn.sourceforge.net/viewvc/osirix/Documentation/Guides/Development/index.html
= Developing Plugins =
== Repository ==
'''svn co https://osirixplugins.svn.sourceforge.net/svnroot/osirixplugins osirixplugins'''

Revision as of 23:21, 30 January 2012

Building OsiriX

Requirements

  1. Mac OS X 10.7 or better
  2. Xcode 4.2 or better

Repository

  1. Main application

svn co https://osirix.svn.sourceforge.net/svnroot/osirix osirix

Build FAQs

  1. Building plugin: Error message "The run destination My Mac 64-bit is no valid for Running the Scheme"
    1. Set Base SDK to MacOS X 10.6.

http://stackoverflow.com/questions/5319251/xcode-4-the-selected-run-destination-is-not-valid-for-this-action

Useful Links

  1. OsiriX Development Guide

http://osirix.svn.sourceforge.net/viewvc/osirix/Documentation/Guides/Development/index.html

Developing Plugins

Repository

svn co https://osirixplugins.svn.sourceforge.net/svnroot/osirixplugins osirixplugins