View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012368CDash(No Category)public2011-07-28 12:312013-08-30 05:49
ReporterSean McBride 
Assigned ToJulien Jomier 
PriorityhighSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.8 
Target VersionFixed in Version2.2 
Summary0012368: CDash's build results html should use monospace font for 'standard error' output
DescriptionTake a look at:

http://www.cdash.org/CDash/viewBuildError.php?buildid=1373522 [^]

in the 'standard error' output, we see:

/Users/builder/kitware/ITK/Modules/Numerics/FEM/include/itkFEMImageMetricLoad.hxx:167:7: error: 'itk::fem::FEMP<itk::fem::Element>' is not a pointer
      dynamic_cast<Element *>( ( *elt ) )->GetIntegrationPointAndWeight(i, ip, w, m_NumberOfIntegrationPoints);
      ^ ~~~~~~~~

the clang compiler outputs nice error messages, but assumes you are using a monospace font. Those ~ characters are meant to underline the "*elt", which is not what one sees with CDash 1.8.3's rendering. See attached screenshot.
TagsNo tags attached.
Attached Filespng file icon Screen Shot 2011-07-28 at 12.29.26.png [^] (223,534 bytes) 2011-07-28 12:31


jpg file icon Win64-Safari.5.1.5.jpg [^] (382,885 bytes) 2012-04-04 12:16

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0027098)
David Cole (manager)
2011-07-28 13:43

Good idea. (I thought it was that way already actually.......)

Should be fairly easy to address...
(0027101)
Sean McBride (reporter)
2011-07-28 17:04

Great! Looking forward to ITK's dashboard being updated...
(0028327)
Julien Jomier (manager)
2012-01-17 04:55

Just tested with CDash 2.0 and it seems to show spaces correctly. Otherwise feel free to reopen.
(0028997)
Sean McBride (reporter)
2012-03-29 11:53

Doesn't seem to be fixed... See for example:

http://open.cdash.org/viewBuildError.php?buildid=2133734 [^]
(0029028)
Julien Jomier (manager)
2012-04-01 11:15

Can you point to an existing build?
(0029036)
Sean McBride (reporter)
2012-04-02 10:07

hmmm, why did that link go dead? Anyway, from today's VTK:

http://open.cdash.org/viewBuildError.php?type=1&buildid=2146444 [^]
(0029055)
David Cole (manager)
2012-04-02 10:14

By the way, this is a problem when viewed from today's up-to-date Safari on a Mac or an iPad. (On my Mac, Lion 10.7.3, Safari 5.1.5. On my iPad, iOS 5.1.)
(0029056)
Sean McBride (reporter)
2012-04-02 10:19

Indeed, it renders correctly for me in FireFox, but not Safari.
(0029076)
Julien Jomier (manager)
2012-04-04 09:08

It works for me with Safari 5.1.5 on Windows...
(0029077)
Sean McBride (reporter)
2012-04-04 11:08

Julien, can you attach a screenshot? It's sounding like a Safari bug... I can file a bug with Apple, but your screenshot would be a convincing argument I think!
(0029078)
Julien Jomier (manager)
2012-04-04 12:16

I just uploaded the screenshot. Thanks!
(0029079)
Sean McBride (reporter)
2012-04-04 13:14

I filed rdar://11183482 with Apple.
(0032426)
Sean McBride (reporter)
2013-03-01 11:08

I finally heard back from Apple yesterday:

---------------------
This is a follow-up regarding regarding Bug ID# 11183482.

Engineering has determined that this issue behaves as intended based on the following information:

On OS X, textareas use a proportional font by default.

The author of the website can specify a monospace font for the text areas if they want to.

If this is still an issue, or you have questions regarding the resolution of this issue, please update your bug report with that information.

We are now closing this bug report.
---------------------
(0033762)
Sean McBride (reporter)
2013-08-29 13:06

Ping. :)

I'm no web expert, but Apple seems to be saying that Safari's behaviour is correct, do you concur?

Even if not, can you specify a monospace font as they suggest?

I should also add that gcc 4.8 now does as clang does, and outputs ASCII art arrows that expect monospaced fonts, see -fdiagnostics-show-caret here:
http://gcc.gnu.org/gcc-4.8/changes.html [^]

This bug is easily my #1 issue with cdash.
(0033763)
Julien Jomier (manager)
2013-08-30 05:49

That was a tricky one. Basically for textarea we need to specify the font-family to be one of the monospace font. By default Safari on Mac (not Windows) doesn't use monopsace font by default.

textarea {
  font-size: 14px;
  font-family: Courier New, Consolas,Monaco,Lucida Console,Liberation Mono,DejaVu Sans Mono,Bitstream Vera Sans Mono, monospace;
}

- Issue History
Date Modified Username Field Change
2011-07-28 12:31 Sean McBride New Issue
2011-07-28 12:31 Sean McBride File Added: Screen Shot 2011-07-28 at 12.29.26.png
2011-07-28 13:42 David Cole Assigned To => David Cole
2011-07-28 13:42 David Cole Status new => assigned
2011-07-28 13:43 David Cole Note Added: 0027098
2011-07-28 17:04 Sean McBride Note Added: 0027101
2012-01-17 03:30 Julien Jomier Assigned To David Cole => Julien Jomier
2012-01-17 04:55 Julien Jomier Note Added: 0028327
2012-01-17 04:55 Julien Jomier Status assigned => resolved
2012-01-17 04:55 Julien Jomier Fixed in Version => 2.0
2012-01-17 04:55 Julien Jomier Resolution open => fixed
2012-03-29 11:53 Sean McBride Note Added: 0028997
2012-03-29 11:53 Sean McBride Status resolved => feedback
2012-03-29 11:53 Sean McBride Resolution fixed => reopened
2012-04-01 11:15 Julien Jomier Note Added: 0029028
2012-04-02 10:07 Sean McBride Note Added: 0029036
2012-04-02 10:07 Sean McBride Status feedback => assigned
2012-04-02 10:14 David Cole Note Added: 0029055
2012-04-02 10:19 Sean McBride Note Added: 0029056
2012-04-04 09:08 Julien Jomier Note Added: 0029076
2012-04-04 11:08 Sean McBride Note Added: 0029077
2012-04-04 12:16 Julien Jomier File Added: Win64-Safari.5.1.5.jpg
2012-04-04 12:16 Julien Jomier Note Added: 0029078
2012-04-04 13:14 Sean McBride Note Added: 0029079
2013-03-01 11:08 Sean McBride Note Added: 0032426
2013-08-29 13:06 Sean McBride Note Added: 0033762
2013-08-30 05:49 Julien Jomier Note Added: 0033763
2013-08-30 05:49 Julien Jomier Status assigned => resolved
2013-08-30 05:49 Julien Jomier Fixed in Version 2.0 => 2.2
2013-08-30 05:49 Julien Jomier Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker