View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011432CDashpublic2010-11-10 02:542011-11-04 15:24
ReporterMichal Cihar 
Assigned ToJulien Jomier 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.9 
Target VersionFixed in Version1.9 
Summary0011432: Undefined variables
DescriptionCDash emits several PHP notices about undefined variables/indexes.
Additional InformationPHP Notice: Undefined variable: projectname in viewCoverage.php on line 67
PHP Notice: Undefined variable: projectname in viewCoverage.php on line 70
PHP Notice: Undefined variable: projectname in viewCoverage.php on line 79
PHP Notice: Undefined variable: project_array in viewCoverage.php on line 79
PHP Notice: Undefined variable: project_array in viewCoverage.php on line 120
PHP Notice: Undefined variable: project_array in viewCoverage.php on line 122
PHP Notice: Undefined variable: project_array in viewCoverage.php on line 125
PHP Notice: Undefined variable: coveragetype in viewCoverage.php on line 212
PHP Notice: Undefined index: c in models/coveragefile.php on line 90
PHP Notice: Undefined variable: coveragefileid in cdash/common.php on line 1017
PHP Notice: Undefined variable: projectname in viewDynamicAnalysis.php on line 51
PHP Notice: Undefined variable: projectname in viewDynamicAnalysis.php on line 55
PHP Notice: Undefined variable: projectname in viewDynamicAnalysis.php on line 63
PHP Notice: Undefined variable: project_array in viewDynamicAnalysis.php on line 63
PHP Notice: Undefined variable: project_array in viewTest.php on line 59
PHP Notice: Undefined variable: projectname in viewTest.php on line 62
PHP Notice: Undefined variable: projectname in viewTest.php on line 66
PHP Notice: Undefined variable: projectname in viewTest.php on line 105
PHP Notice: Undefined index: nightlytime in cdash/common.php on line 1270
PHP Notice: Undefined variable: projectname in viewTest.php on line 106
PHP Notice: Undefined variable: project_array in viewTest.php on line 130
PHP Notice: Undefined variable: projectshowtesttime in viewTest.php on line 170
PHP Notice: Undefined variable: project_array in viewCoverageFile.php on line 51
PHP Notice: Undefined variable: projectname in viewCoverageFile.php on line 55
PHP Notice: Undefined variable: projectname in viewCoverageFile.php on line 59
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0023121)
Julien Jomier (manager)
2010-11-10 03:42

It seems that for these pages either the buildid is not valid anymore in the database (build has been removed). Could you check that the link is valid from the main dashboard?
(0023122)
Michal Cihar (reporter)
2010-11-10 04:46

Some of these happen on submission (eg. PHP Notice: Undefined index: c in models/coveragefile.php on line 90 and PHP Notice: Undefined variable: coveragefileid in cdash/common.php on line 1017), so it must be problem somewhere.

The rest seems to be indeed for non existing builds, however I think it should produce rather some error page than failing silently.
(0023124)
Julien Jomier (manager)
2010-11-10 04:58

Should be better now. Let me know otherwise. Thanks for the report!
(0023157)
Michal Cihar (reporter)
2010-11-11 02:51

Unfortunately there are still some left.

These (probably) happen on browsing some non existing builds:

PHP Notice: Undefined index: nightlytime in cdash/common.php on line 1270
PHP Notice: Undefined variable: projectname in viewConfigure.php on line 51
PHP Notice: Undefined variable: project_array in viewConfigure.php on line 55
PHP Notice: Undefined variable: projectname in viewConfigure.php on line 56
PHP Notice: Undefined variable: projectname in viewConfigure.php on line 65

And I get dozens of these on submission:

PHP Notice: Undefined variable: coveragefileid in cdash/common.php on line 1017

What leads to empty file list in coverage (for example https://cdash.cihar.com/viewCoverage.php?buildid=11215 [^] ) and then:

PHP Notice: Undefined variable: coveragetype in viewCoverage.php on line 218
(0023159)
Julien Jomier (manager)
2010-11-11 03:31

Thanks a lot for the report. I have committed the fixes, let me know if more are showing up. However I don't know why you don't get a list of coverage...
(0027727)
Julien Jomier (manager)
2011-11-04 15:24

Please reopen if this is still happening

- Issue History
Date Modified Username Field Change
2010-11-10 02:54 Michal Cihar New Issue
2010-11-10 03:32 Julien Jomier Status new => assigned
2010-11-10 03:32 Julien Jomier Assigned To => Julien Jomier
2010-11-10 03:42 Julien Jomier Note Added: 0023121
2010-11-10 04:46 Michal Cihar Note Added: 0023122
2010-11-10 04:58 Julien Jomier Note Added: 0023124
2010-11-10 04:58 Julien Jomier Status assigned => resolved
2010-11-10 04:58 Julien Jomier Fixed in Version => 1.8
2010-11-10 04:58 Julien Jomier Resolution open => fixed
2010-11-11 02:51 Michal Cihar Note Added: 0023157
2010-11-11 02:51 Michal Cihar Status resolved => feedback
2010-11-11 02:51 Michal Cihar Resolution fixed => reopened
2010-11-11 03:31 Julien Jomier Note Added: 0023159
2011-11-04 15:24 Julien Jomier Note Added: 0027727
2011-11-04 15:24 Julien Jomier Status feedback => resolved
2011-11-04 15:24 Julien Jomier Fixed in Version 1.8 => 1.9
2011-11-04 15:24 Julien Jomier Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker