View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010721CDashpublic2010-05-17 06:312010-10-25 02:36
ReporterRolf Eike Beer 
Assigned ToJulien Jomier 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version1.8 
Target VersionFixed in Version1.8 
Summary0010721: Showing build errors (the yellow triangle) does not work
DescriptionURL is like .../cdash/viewErrorLog.php?buildid=2010&projectid=1&date=

Error is

Fatal error: Call to a member function fetch() on a non-object in .../cdash/cdash/pdo.php on line 121

This is PostgreSQL 8.4.2.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0020759)
Julien Jomier (manager)
2010-05-17 12:17
edited on: 2010-05-17 12:19

Could you make sure that you have a errorlog table. It seems that your upgrade didn't work as expect and that might be the problem. Otherwise let me know if you have any other logs in the php/apache logs. Actually the date is not set, let me put a fix in SVN.

(0020760)
Julien Jomier (manager)
2010-05-17 12:30

Should be better now. Otherwise let me know.
(0020777)
Rolf Eike Beer (reporter)
2010-05-18 02:03

Now I get these:

(compute_error_difference): SQL error: ERROR: column "crc32" does not exist LINE 2: (SELECT crc32 FROM (SELECT crc32 FROM buildfa... ^
(0020780)
Julien Jomier (manager)
2010-05-18 09:09

Could you check that you have a column crc32 in the buildfailure column?
(0020781)
Rolf Eike Beer (reporter)
2010-05-18 09:14

Of course not ;( But shouldn't that one have been created by the upgrade script?
(0020782)
Julien Jomier (manager)
2010-05-18 09:16

Yes it should.... could you try to upgrade again and see if that works? otherwise I'll take a look...
(0020783)
Rolf Eike Beer (reporter)
2010-05-18 09:21

Tried the upgrade script like 3 times today (r2352)

Find me in #cmake on Freenode, this should make things faster.
(0020923)
Rolf Eike Beer (reporter)
2010-06-04 04:58

I now created crc32 and newstatus columns by hand. For me it looks like they were never added to the cdash-upgrade-* files so they will not exist if an existing installation is upgraded.

- Issue History
Date Modified Username Field Change
2010-05-17 06:31 Rolf Eike Beer New Issue
2010-05-17 12:09 Julien Jomier Status new => assigned
2010-05-17 12:09 Julien Jomier Assigned To => Julien Jomier
2010-05-17 12:17 Julien Jomier Note Added: 0020759
2010-05-17 12:19 Julien Jomier Note Edited: 0020759
2010-05-17 12:30 Julien Jomier Note Added: 0020760
2010-05-17 12:30 Julien Jomier Status assigned => resolved
2010-05-17 12:30 Julien Jomier Fixed in Version => 1.8
2010-05-17 12:30 Julien Jomier Resolution open => fixed
2010-05-18 02:03 Rolf Eike Beer Note Added: 0020777
2010-05-18 02:03 Rolf Eike Beer Status resolved => feedback
2010-05-18 02:03 Rolf Eike Beer Resolution fixed => reopened
2010-05-18 09:09 Julien Jomier Note Added: 0020780
2010-05-18 09:14 Rolf Eike Beer Note Added: 0020781
2010-05-18 09:16 Julien Jomier Note Added: 0020782
2010-05-18 09:21 Rolf Eike Beer Note Added: 0020783
2010-06-04 04:58 Rolf Eike Beer Note Added: 0020923
2010-10-25 02:36 Julien Jomier Status feedback => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker