FW: [Insight-developers] Passing arrays of parameters around: adding itk::FixedArray<> ?

Lydia Ng lng@insightful.com
Wed, 20 Feb 2002 09:54:11 -0800


> Or would DynamicArray lead people to believe that they could=20
> change its length
> after constructor time?

I agree - the term DynamicArray would lead people to think that
they can resize the length.

I would be happy with FixedArray and Array.

- Lydia


> -----Original Message-----
> From: Miller, James V (CRD) [mailto:millerjv@crd.ge.com]
> Sent: Wednesday, February 20, 2002 6:36 AM
> To: 'Luis Ibanez'; Lydia Ng
> Cc: insight-developers@public.kitware.com
> Subject: RE: [Insight-developers] Passing arrays of parameters around:
> adding itk::FixedArray<> ?
>=20
>=20
> Do we want FixedArray and Array or an Array (which is fixed)=20
> and a DynamicArray?
>=20
> Or would DynamicArray lead people to believe that they could=20
> change its length
> after constructor time?
>=20
> The reason I ask is that I will probably be writing a=20
> DynamicJoinImageFilter which would join N input
> images forming a vector image whose length is not known at=20
> the time the filter is constructed, making
> it different from the current JoinImageFilter. I am wondering=20
> if I should pick a different name.
>=20
>=20
> -----Original Message-----
> From: Luis Ibanez [mailto:luis.ibanez@kitware.com]
> Sent: Wednesday, February 20, 2002 8:23 AM
> To: Lydia Ng
> Cc: insight-developers@public.kitware.com
> Subject: [Insight-developers] Passing arrays of parameters around:
> adding itk::FixedArray<> ?
>=20
>=20
>=20
> How about adding a variant of itk::Array<>, templated only over
> the representation type and defining the Dimension (once and for all)
> at construction time ( a bit like the vnl_vector_fixed class ).
>=20
> We could rename the current itk::Array<>  as itk::FixedArray<> and
> add this new variant. Its code will be almost a copy of the current
> itk::Array<>.
>=20
>=20
>=20
>      Luis
>=20
>=20
> =
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D
>=20
> Lydia Ng wrote:
>=20
> >
> >As a group should we lock down on a consistent way of passing
> >around a variable sized array for all filters
> >- in some places people have used (T *) and in other
> >places people have used (std::vector<T> &)
> >
> >Comments?
> >
> >- Lydia
> >
>=20
>=20
> _______________________________________________
> Insight-developers mailing list
> Insight-developers@public.kitware.com
> http://public.kitware.com/mailman/listinfo/insight-developers
>=20