View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009663CDash[CMake] CTestpublic2009-10-05 12:132011-12-23 12:46
ReporterSean McBride 
Assigned ToJulien Jomier 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMac OS XOSMac OS XOS Version10.5
Product Version 
Target VersionFixed in Version2.0 
Summary0009663: CTest/CDash OS version & compiler information is lacking on Mac OS X
DescriptionCTest/CDash reports at the top of a dashboard page various OS information. For example:

http://www.cdash.org/CDash/buildSummary.php?buildid=201967 [^] [^]

shows:

OS Name: Darwin
OS Platform: Power Macintosh
OS Release: 9.5.0
OS Version: Darwin Kernel Version 9.5.0: Wed Sep 3 11:31:44 PDT 2008; root:xnu-1228.7.58~1/RELEASE_PPC

This information is not ideal. Very few people use plain Darwin as opposed to the full Mac OS X (Darwin is the open source part, available separately).

I think the following would be more useful:

OS Name: Mac OS X
OS Platform: Power Macintosh
OS Release: 10.5.5
OS Version: 9F33

You can get that info by running 'sw_vers' in the terminal. Example:

$ sw_vers
ProductName: Mac OS X
ProductVersion: 10.5.5
BuildVersion: 9F33

See its man page.

The current gory details of the kernel version and not so helpful, because most everyone use OS X, not Darwin, and its kernel is never updated separately.


Additionally, it seems unable to detect the compiler. Ex:

http://www.cdash.org/CDash/buildSummary.php?buildid=440701 [^] [^]

shows:

Compiler Name: unknown
Compiler Version: unknown

This is most unfortunate since both 10.5 and 10.6 each ship with several compilers: gcc 4.2, llvm-gcc, and clang. All 3 respond to the --version argument:

On 10.6.1 with Xcode 3.2 for example:

$ clang --version
clang version 1.0 (http://llvm.org/svn/llvm-project/cfe/tags/Apple/clang-23 [^] [^] exported)

$ gcc-4.2 --version
i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5646)

$ llvm-gcc --version
i686-apple-darwin10-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5646) (LLVM build 2118)
TagsNo tags attached.
Attached Filespatch file icon 0001-Fix-CPU-speed-calculations.patch [^] (1,795 bytes) 2010-11-11 11:25 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
has duplicate 0007838closed CDash OS information is not ideal on Mac OS X 

-  Notes
(0018034)
Zach Mullen (developer)
2009-10-08 13:18

Checked in a fix for this issue
(Added better OS information for Mac OS X)
(0018050)
Sean McBride (reporter)
2009-10-09 10:36

After your changes:
http://www.cdash.org/CDash/buildSummary.php?buildid=445598 [^]

OS Name: Mac OS X
OS Platform: i386
OS Release: 10.6.1
OS Version: 10B504
Compiler Name: unknown
Compiler Version: unknown

Definitely improved! But:

1) the compiler is still not detected.
2) what is "OS Platform" supposed to mean? The kind of CPU? How do you get it? from uname? I ask because both my 32 bit and my 64 bit dashboards both report "i386". Not sure if that's deliberate.
(0018051)
Zach Mullen (developer)
2009-10-09 10:39

The OS Platform does refer to the processor architecture. Both 32 bit and 64 bit machines can be x86 architecture.

As for the compiler, ctest/cmake has no knowledge of the compiler currently. CDash also does not support compiler information, so I'm not entirely sure why those two records even appear in CDash...
(0018052)
Sean McBride (reporter)
2009-10-09 10:46

Thanks Zack. Is there another bug covering "ctest/cmake has no knowledge of the compiler currently"? Or should I create it?
(0018059)
Zach Mullen (developer)
2009-10-12 11:21

I've just checked in some changes to give some rudimentary compiler information reporting.

You won't see this change reflected unless you update both CMake and CDash.
(0018094)
Sean McBride (reporter)
2009-10-17 13:20

I've found some more missing info:
http://www.cdash.org/CDash/viewSite.php?siteid=1987&project=11&currenttime=1255654800 [^]

Processor Speed: 2.1GHz
64 Bits: NA
Processor Vendor: -1
Processor Vendor ID: -1
Processor Family ID: NA
Processor Cache Size: 32768
Number of logical CPUs: NA
Number of physical CPUs: NA
Number of logical CPU per Physical CPUs: 2
Total Virtual Memory: 1024MB
Total Physical Memory: 4GB
Description: NA

Though looking around at other dashboards, this does not seem to be a Mac-only problem.

Note that some of the above is missing, and some is wrong. "Total Virtual Memory: 1024MB" Note sure what that's supposed to mean, but on OS X a process has either 2^32 or 2^64 bits of virtual memory.
(0018100)
Bill Hoffman (manager)
2009-10-19 08:52

This is a CDash issue. Should be fixed in the next version of CDAsh.
(0021243)
Sean McBride (reporter)
2010-07-05 15:09

Although definitely better than when I first created this bug, things are not fully fixed yet.

Using my own dashboards as examples:

1) "Compiler Version: unknown"
See: http://www.cdash.org/CDash/buildSummary.php?buildid=656063 [^]

I'd like to see it recognise gcc and clang, and the version thereof.

2) machine info is largely wrong
See: http://www.cdash.org/CDash/viewSite.php?siteid=2568&project=1&currenttime=1278291600 [^]

a) This machine is 2.26 GHz not 2.1

b) 64 Bits: 0. This machine is a Core 2 Duo which is 64 bit.

c) "Processor Family ID: 6" -> not useful. What's "6"? Could it report "Core 2 Duo" instead?

d) "Processor Cache Size: 32768" -> not useful. is that bytes? KB? MB? L2? L3? This machine has 3 MB of L2 cache.

e) "total virtual memory" is not 11 GB. What does that even mean? on OS X a process has either 2^32 or 2^64 bits of virtual memory.
(0021247)
Rolf Eike Beer (reporter)
2010-07-06 01:12

e) "total virtual memory" is RAM+Swap AFAICT.

b) is this a 64 bit compiler?

c) see also bug 10895
(0021248)
Rolf Eike Beer (reporter)
2010-07-06 01:22

1) is a dupe of 7867
(0021252)
Sean McBride (reporter)
2010-07-06 09:50

e) It doesn't seem to be RAM+swap, see:
http://www.cdash.org/CDash/viewSite.php?siteid=53&project=1&currenttime=1278378000 [^]

Total Virtual Memory: 512MB
Total Physical Memory: 5GB

b) given that the "64 Bits" part is between other processor attributes, I didn't consider that it might refer to the compiler. Are you sure it does? If so, what does "64 bit compiler" even mean, especially with cross compilation, etc.
(0021254)
Rolf Eike Beer (reporter)
2010-07-06 11:19

You are right, since this is a "platform" attribute it must belong to the host. See also 0007866.

The virtual memory looks very confusing. Could that be _only_ the swap size? That would at least match my platforms.

And for QNX hosts the complete information is missing.
(0023146)
David Cole (manager)
2010-11-10 14:15

This is another "SystemInformation is deficient in spots" problem...
(0023164)
David Cole (manager)
2010-11-11 08:00

I have read through all the notes on this bug. I am confused about what the bug is about anymore. Seems like it's sorta fixed, but not all the way.

Sean, (and anybody else listening), could you please clarify:
- what is still broken or missing as of ctest 2.8.3 and CDash 1.8.1?
- what do you expect the resolution of this bug to be? (i.e., if this were fixed entirely, how would I be able to tell?)

Thanks,
David Cole
(0023174)
Sean McBride (reporter)
2010-11-11 10:23
edited on: 2011-01-05 14:11

David,

Yes, this bug has become crowded... and things are certainly better since I filed it.

Comment 0009663:0021243 has a pretty good recap, but here's a new one:


1) "Compiler Version: unknown"
covered by bug 0007867

2) machine info is wrong/confusing
See: http://www.cdash.org/CDash/viewSite.php?siteid=1987&project=1&currenttime=1289437200 [^]

a) This machine is 2.26 GHz not 2.1. Someone sent a patch for this recently on the cmake list...

b) is is64Bits issue is covered by bug 0007866

c) "Processor Family ID: 6" -> not useful. What's "6"? Could it report a more human-friendly string, like "Core 2 Duo" instead? See also bug 0010895

d) "Processor Cache Size: 32768" -> not useful. for one, units are missing. KB? MB? KiB? MiB? And which cache? L2? L3?

e) "total virtual memory" What does that even mean? on Unix a process has either 2^32 or 2^64 bits of virtual memory.

f) "total physical memory" has the correct value, but consider using "GiB" instead of "GB" (ie base 2 prefixes)


Basically, the spirit of this bug, as per its title, is: it's nice to have all this detailed info, but it's currently wrong/confusing, and that should be fixed.

I guess I'd consider it fixed when I look at a page like:
http://www.cdash.org/CDash/viewSite.php?siteid=1987&project=1&currenttime=1289437200 [^]

and don't have to scratch my head. :)

(0023175)
Rolf Eike Beer (reporter)
2010-11-11 11:27

This is the fix for a)

So the remaining point is to actually define what things like "processor cache size" and "total virtual memory" and the different CPU counts (logical/physical etc.) really should mean.
(0024439)
David Cole (manager)
2011-01-05 15:54

In this commit's message:
http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=1c2a9b8140829ba886d67bca084ee40eb0a20b84 [^]

...I inadvertently made a typo that references another bug, 0009963. The commit actually fixes part of this bug 0009663, and this is the one that I should have referenced in the commit message. Sorry for the confusion.
(0024440)
David Cole (manager)
2011-01-05 15:56

As far as I can see, this bug is as fixed as it's going to get on the ctest side of things.

I am going to "move" it over to the CDash project now and assign it to Julien, to see what his opinion is on the display of information on the viewSite.php page.

If there is something specific that is not being reported correctly by ctest, then please open another issue with a specific problem mentioned.

Many of these are probably already covered by the other related issues to this one.

Thanks for all your patience as we slowly make this stuff better.
(0024441)
David Cole (manager)
2011-01-05 16:00

Julien,

See my comments in the most recent notes. Nothing urgent about fixing this "very soon" on the CDash-side, but it would be nice to revamp the viewSite.php page so that it makes sense and has accurate information on it.

See all the notes for all the complaints.

Feel free to re-assign if you're not the appropriate owner for this one.
(0027188)
Sean McBride (reporter)
2011-08-10 14:37

Any news on this bug?
(0028060)
Julien Jomier (manager)
2011-12-23 08:11

I cleanup the viewSite page on CDash (will be in the 2.0 release). I removed the information that were not clear. Basically the information left are these ones:

Processor Speed: 2.43GHz
Processor Vendor: GenuineIntel (Intel Corporation)
Number of CPUs: 1
Number of Cores: 4
Total Physical Memory: 2.91GB

Feel free to reopen if I missed anything. Thanks again for reporting these issues.
(0028067)
Sean McBride (reporter)
2011-12-23 10:56

Cool! Is there a public cdash 2.0 running somewhere that I can look at?
(0028068)
Julien Jomier (manager)
2011-12-23 10:58

http://slicer.cdash.org [^]
(0028069)
Sean McBride (reporter)
2011-12-23 11:10

Very nice. Looking forward to its release! Some comments:

- 2.91 GB? Is that base 10? I'd suggest writing 3.0 GiB, so there's no confusion.

Also, the two actual issues in the title of this bug don't seem to have been addressed: does it show OS and compiler version anywhere?
(0028070)
Julien Jomier (manager)
2011-12-23 12:18

I just changed the GB to GiB, I agree it makes more sense.

The OS and compiler versions are shown per build basis (not machine) since a machine can have several compilers/OS.
(0028071)
Sean McBride (reporter)
2011-12-23 12:42

Great, thanks! You can 'resolve' again...

- Issue History
Date Modified Username Field Change
2009-10-05 12:13 Sean McBride New Issue
2009-10-05 12:22 Bill Hoffman Status new => assigned
2009-10-05 12:22 Bill Hoffman Assigned To => Zach Mullen
2009-10-05 13:17 Brad King Relationship added has duplicate 0007838
2009-10-05 14:02 Zach Mullen Status assigned => acknowledged
2009-10-08 13:18 Zach Mullen Note Added: 0018034
2009-10-08 13:19 Zach Mullen Status acknowledged => resolved
2009-10-08 13:19 Zach Mullen Fixed in Version => CMake-2-8
2009-10-08 13:19 Zach Mullen Resolution open => fixed
2009-10-09 10:36 Sean McBride Note Added: 0018050
2009-10-09 10:36 Sean McBride Status resolved => feedback
2009-10-09 10:36 Sean McBride Resolution fixed => reopened
2009-10-09 10:39 Zach Mullen Note Added: 0018051
2009-10-09 10:46 Sean McBride Note Added: 0018052
2009-10-12 11:21 Zach Mullen Note Added: 0018059
2009-10-12 11:22 Zach Mullen Status feedback => resolved
2009-10-12 11:22 Zach Mullen Resolution reopened => fixed
2009-10-17 13:20 Sean McBride Note Added: 0018094
2009-10-17 13:20 Sean McBride Status resolved => feedback
2009-10-17 13:20 Sean McBride Resolution fixed => reopened
2009-10-19 08:52 Bill Hoffman Note Added: 0018100
2009-10-19 08:52 Bill Hoffman Status feedback => assigned
2009-10-19 08:52 Bill Hoffman Assigned To Zach Mullen => Julien Jomier
2010-07-05 15:09 Sean McBride Note Added: 0021243
2010-07-06 01:12 Rolf Eike Beer Note Added: 0021247
2010-07-06 01:22 Rolf Eike Beer Note Added: 0021248
2010-07-06 09:50 Sean McBride Note Added: 0021252
2010-07-06 11:19 Rolf Eike Beer Note Added: 0021254
2010-11-10 14:15 David Cole Note Added: 0023146
2010-11-10 14:17 David Cole Fixed in Version CMake-2-8 =>
2010-11-10 14:17 David Cole Target Version => CMake 2.8.4
2010-11-11 07:52 David Cole Assigned To Julien Jomier => David Cole
2010-11-11 08:00 David Cole Note Added: 0023164
2010-11-11 10:23 Sean McBride Note Added: 0023174
2010-11-11 11:25 Rolf Eike Beer File Added: 0001-Fix-CPU-speed-calculations.patch
2010-11-11 11:27 Rolf Eike Beer Note Added: 0023175
2011-01-05 14:11 David Cole Note Edited: 0023174 View Revisions
2011-01-05 15:54 David Cole Note Added: 0024439
2011-01-05 15:56 David Cole Note Added: 0024440
2011-01-05 15:58 David Cole Project CMake => CDash
2011-01-05 15:59 David Cole Assigned To David Cole => Julien Jomier
2011-01-05 16:00 David Cole Note Added: 0024441
2011-08-10 14:37 Sean McBride Note Added: 0027188
2011-12-23 08:11 Julien Jomier Note Added: 0028060
2011-12-23 08:11 Julien Jomier Status assigned => resolved
2011-12-23 08:11 Julien Jomier Fixed in Version => 2.0
2011-12-23 08:11 Julien Jomier Resolution reopened => fixed
2011-12-23 10:56 Sean McBride Note Added: 0028067
2011-12-23 10:56 Sean McBride Status resolved => feedback
2011-12-23 10:56 Sean McBride Resolution fixed => reopened
2011-12-23 10:58 Julien Jomier Note Added: 0028068
2011-12-23 11:10 Sean McBride Note Added: 0028069
2011-12-23 11:10 Sean McBride Status feedback => assigned
2011-12-23 12:18 Julien Jomier Note Added: 0028070
2011-12-23 12:42 Sean McBride Note Added: 0028071
2011-12-23 12:46 Julien Jomier Status assigned => resolved
2011-12-23 12:46 Julien Jomier Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker