View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008803CMakeModulespublic2009-03-27 13:242010-09-01 00:13
ReporterKeith Gardner 
Assigned ToPhilip Lowman 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionCMake-2-6 
Target VersionFixed in Version 
Summary0008803: Want to know what Visual Studio service pack is installed.
DescriptionI need to know what service pack is installed for the version of Visual Studio I am trying to use. I currently am reading the registry key [HKEY_LOCAL_MACHINE\Software\Microsoft\DevDiv\VS\Servicing\9.0] to get the value for Visual Studio 2008 but I would like to have CMake get the information for me.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0015913)
Philip Lowman (developer)
2009-04-04 02:32

Can you send along the output of running "cl" in a Visual Studio 2008 Command Prompt both with & without SP1. If you can do this, I will write a CMake module for this.

Here's an example of what the output of VS8 SP1 looks like. I already have the exact version numbers for VS8 (Gold and SP1). I just need the same for VS9 (Gold & SP1) to write the script.

C:\Temp\Copy of Start>cl
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86
(0015935)
Keith Gardner (reporter)
2009-04-06 13:41

Visual Studio 2008 Without SP1
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.21022.08 for 80x86

Visual Studio 2008 With SP1
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86

Visual Studio 2005 Without SP1
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.42 for 80x86
(0016012)
Philip Lowman (developer)
2009-04-14 00:56

Thanks for the version numbers. I checked CMakeDetermineVSServicePack.cmake into CVS. You can grab a copy here.

http://www.cmake.org/cgi-bin/viewcvs.cgi/Modules/CMakeDetermineVSServicePack.cmake?root=CMake&view=markup [^]

- Issue History
Date Modified Username Field Change
2009-03-27 13:24 Keith Gardner New Issue
2009-04-04 02:32 Philip Lowman Note Added: 0015913
2009-04-04 02:32 Philip Lowman Assigned To => Philip Lowman
2009-04-04 02:32 Philip Lowman Status new => assigned
2009-04-04 02:32 Philip Lowman Category CMake => Modules
2009-04-06 13:41 Keith Gardner Note Added: 0015935
2009-04-14 00:56 Philip Lowman Note Added: 0016012
2009-04-14 00:56 Philip Lowman Status assigned => resolved
2009-04-14 00:56 Philip Lowman Resolution open => fixed
2010-09-01 00:13 Philip Lowman Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker