View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013464CMakeCMakepublic2012-08-10 02:412012-08-13 14:55
ReporterAlexander Broekhuis 
Assigned ToAlex Neundorf 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAppleOSOS XOS Version10.6.8
Product VersionCMake 2.8.8 
Target VersionCMake 2.8.10Fixed in Version 
Summary0013464: Generated Eclipse project file contains wrong paths
DescriptionThe Eclipse project file generator produces wrong paths for 2 entries:

/System/Library/Frameworks (framework directory)
/Library/Frameworks (framework directory)

The ending part ((framework directory)) should not be there. This results in warnings in Eclipse, and potentially an incorrect lookup path for includes.
Steps To ReproduceGenerate Eclipse project files using:

cmake -G"Eclipse CDT4 - Unix Makefiles" ../project
Additional InformationFollowing Alexander Neundorf his request I have attached the output of "g++ -v -E -x c++ -dD /dev/null".
TagsNo tags attached.
Attached Files? file icon gpp [^] (5,251 bytes) 2012-08-10 02:41 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0030211)
Alex Neundorf (developer)
2012-08-10 15:49

Can you give the HandleMacFrameworkIncludeDirs_13465 branch on cmake stage a try ?
 http://cmake.org/gitweb?p=stage/cmake.git [^] [^]
It should be stripping that part now.
It's a bit unfortunate that cmake 2.8.9 has been released just today...
(0030464)
Alexander Broekhuis (reporter)
2012-08-13 05:33

Hi, the mentioned branch works. The part is now indeed gone. Thanks for the quick fix.

When is the next planned release?
(0030568)
Alex Neundorf (developer)
2012-08-13 11:59

Since 2.8.9 has just been released, in about 3 months from now.
So this is about the longest possible time you have to wait. :-/
(0030581)
Alex Neundorf (developer)
2012-08-13 14:55

Just adjusting the version number...

- Issue History
Date Modified Username Field Change
2012-08-10 02:41 Alexander Broekhuis New Issue
2012-08-10 02:41 Alexander Broekhuis File Added: gpp
2012-08-10 15:08 Alex Neundorf Assigned To => Alex Neundorf
2012-08-10 15:08 Alex Neundorf Status new => assigned
2012-08-10 15:49 Alex Neundorf Note Added: 0030211
2012-08-13 05:33 Alexander Broekhuis Note Added: 0030464
2012-08-13 11:59 Alex Neundorf Note Added: 0030568
2012-08-13 11:59 Alex Neundorf Status assigned => closed
2012-08-13 11:59 Alex Neundorf Resolution open => fixed
2012-08-13 14:55 Alex Neundorf Note Added: 0030581
2012-08-13 14:55 Alex Neundorf Status closed => feedback
2012-08-13 14:55 Alex Neundorf Resolution fixed => reopened
2012-08-13 14:55 Alex Neundorf Status feedback => closed
2012-08-13 14:55 Alex Neundorf Resolution reopened => fixed
2012-08-13 14:55 Alex Neundorf Target Version => CMake 2.8.10


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker