View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012649CMakeQtDialogpublic2012-01-02 12:192013-03-04 08:38
Reportervoid.pointer 
Assigned ToClinton Stimpson 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWindowsOS VersionWindows
Product VersionCMake 2.8.7 
Target VersionCMake 2.8.8Fixed in VersionCMake 2.8.10 
Summary0012649: Pressing "stop" should interrupt blocking functions in cmake-gui (QtDialog)
DescriptionOriginally reported on the mailing list. See discussion here:
http://www.cmake.org/pipermail/cmake/2011-December/048316.html [^]

Attached is the patch file provided by Clinton to supposedly fix the issue (I haven't tested it)
TagsNo tags attached.
Attached Filespatch file icon interrupt.patch [^] (6,414 bytes) 2012-01-02 12:19 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0028088)
Clinton Stimpson (developer)
2012-01-02 13:12

http://cmake.org/gitweb?p=cmake.git;a=commit;h=131eed [^]
(0030873)
David Cole (manager)
2012-09-03 16:01

Closing resolved issues that have not been updated in more than 4 months.
(0030899)
void.pointer (reporter)
2012-09-03 16:16

This technically isn't resolved yet, since the stop button no longer stops like it supposed to. When I press STOP, during configure, sometimes it ends with no failure and I am able to generate a partially configured session.
(0030909)
Clinton Stimpson (developer)
2012-09-04 10:54

52ec845 cmake-gui: Fix error status when interrupted.
(0032438)
Robert Maynard (manager)
2013-03-04 08:38

Closing resolved issues that have not been updated in more than 4 months.

- Issue History
Date Modified Username Field Change
2012-01-02 12:19 void.pointer New Issue
2012-01-02 12:19 void.pointer File Added: interrupt.patch
2012-01-02 13:06 David Cole Target Version => CMake 2.8.8
2012-01-02 13:11 Clinton Stimpson Assigned To => Clinton Stimpson
2012-01-02 13:11 Clinton Stimpson Status new => assigned
2012-01-02 13:12 Clinton Stimpson Note Added: 0028088
2012-01-02 13:12 Clinton Stimpson Status assigned => resolved
2012-01-02 13:12 Clinton Stimpson Resolution open => fixed
2012-04-19 15:44 David Cole Fixed in Version => CMake 2.8.8
2012-09-03 16:01 David Cole Note Added: 0030873
2012-09-03 16:01 David Cole Status resolved => closed
2012-09-03 16:16 void.pointer Note Added: 0030899
2012-09-03 16:16 void.pointer Status closed => feedback
2012-09-03 16:16 void.pointer Resolution fixed => reopened
2012-09-04 10:54 Clinton Stimpson Note Added: 0030909
2012-09-04 10:54 Clinton Stimpson Status feedback => resolved
2012-09-04 10:54 Clinton Stimpson Fixed in Version CMake 2.8.8 => CMake 2.8.10
2012-09-04 10:54 Clinton Stimpson Resolution reopened => fixed
2013-03-04 08:38 Robert Maynard Note Added: 0032438
2013-03-04 08:38 Robert Maynard Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker