View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011030CMakeCMakepublic2010-07-22 18:052010-12-14 18:50
ReporterOlaf van der Spek 
Assigned ToDavid Cole 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product VersionCMake-2-8 
Target VersionCMake 2.8.3Fixed in Version 
Summary0011030: Decorate library names
DescriptionIt'd be great if library names could be decorated. That way, all files can be stored in a single lib dir from which the linker can pick the right variant.

The decoration should specify:
Debug vs Release
Dynamic vs Static
Dynamic vs Static Runtime
x86 vs x64
Compiler (maybe)
Threading (maybe)

See for example http://www.boost.org/doc/libs/1_43_0/more/getting_started/windows.html#library-naming [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0021554)
Brad King (manager)
2010-07-29 12:47

The OUTPUT_NAME and OUTPUT_NAME_<CONFIG> target properties

  http://www.cmake.org/cmake/help/cmake-2-8-docs.html#prop_tgt:OUTPUT_NAME [^]

provide all the tools needed to do this. Each project will define its own scheme for this; we do not want to offer or enforce one.
(0021557)
Olaf van der Spek (reporter)
2010-07-29 13:25

As a hypothetical library developer, I've no idea about platform-specific naming conventions. I don't want to have any idea about this either.
What's the reason to require every single lib dev to duplicate this code?
I think a scheme should at least be offered!
(0021945)
David Cole (manager)
2010-08-25 07:46

This is beyond the scope of what CMake offers.

If you think a scheme should be offered, then offer a scheme in the form of a well-tested patch to the CMake source tree.

There is no concensus about this issue on the CMake mailing list among its current heavy users. Therefore, there is no "right way" to address this.

If a scheme that could be generally agreed upon could be offered, then we could consider adding this feature. Until that happens, none of the core CMake devs are really interested in spending their time on developing this feature.

The basic functionality to allow you to name things according to your chosen scheme is there and works everywhere that CMake works. (See previous notes in this bug.)

Choosing your scheme is up to you.
(0024100)
David Cole (manager)
2010-12-14 18:50

Closing bugs that have been resolved for more than 3 months without any further updates.

- Issue History
Date Modified Username Field Change
2010-07-22 18:05 Olaf van der Spek New Issue
2010-07-29 12:47 Brad King Note Added: 0021554
2010-07-29 12:48 Brad King Status new => closed
2010-07-29 12:48 Brad King Resolution open => won't fix
2010-07-29 13:25 Olaf van der Spek Note Added: 0021557
2010-07-29 13:25 Olaf van der Spek Status closed => feedback
2010-07-29 13:25 Olaf van der Spek Resolution won't fix => reopened
2010-08-25 07:43 David Cole Status feedback => assigned
2010-08-25 07:43 David Cole Assigned To => David Cole
2010-08-25 07:46 David Cole Note Added: 0021945
2010-08-25 07:46 David Cole Status assigned => resolved
2010-08-25 07:46 David Cole Resolution reopened => won't fix
2010-08-31 18:13 David Cole Target Version => CMake 2.8.3
2010-12-14 18:50 David Cole Note Added: 0024100
2010-12-14 18:50 David Cole Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker